zoukankan      html  css  js  c++  java
  • poj 2429 GCD & LCM Inverse 【java】+【数学】

    GCD & LCM Inverse
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 9928   Accepted: 1843

    Description

    Given two positive integers a and b, we can easily calculate the greatest common divisor (GCD) and the least common multiple (LCM) of a and b. But what about the inverse? That is: given GCD and LCM, finding a and b.

    Input

    The input contains multiple test cases, each of which contains two positive integers, the GCD and the LCM. You can assume that these two numbers are both less than 2^63.

    Output

    For each test case, output a and b in ascending order. If there are multiple solutions, output the pair with smallest a + b.

    Sample Input

    3 60

    Sample Output

    12 15
    题意:给出你最大公约数和最小公倍数,让你求出原来的两个数a,b。特别的假设有多组的话,输出和最小的哪一组。

    分析:由GCD和LCM之间的关系可得a*b/GCD= LCM; 没有特别的方法仅仅好枚举,可是我们能够得出a*b = LCM/GCD。我们要找的是最后的和最小的,所以从sqrt(b/=a)開始到1枚举就好了。

    注:假设用c/c++会超时的。最后经学长指导改用java就过了。。。

    又学了一招。

    代码:

    import java.util.Scanner;
    import java.math.*;
    
    public class Main{
    	public static void main(String[] args){
    		Scanner cin = new Scanner(System.in);
    		long a, b, x, y;
    		while(cin.hasNext()){
    			a = cin.nextLong();
    			b = cin.nextLong();
    			x = y = 0;
    			b /= a;
    			for(long i = (long)Math.sqrt(b); i > 0; i --){
    				if(b%i == 0&&gcd(i, b/i) == 1){
    					x = i*a; y = b/i*a; break;
    				}
    			}
    			System.out.println(x+" "+y);
    		}
    	}
    	public static long gcd(long a, long b){
    		if(a<b){
    			long t =a; a = b; b = t;
    		}
    		if(b == 0) return a;
    		else return gcd(b, a%b);
    	}
    }



  • 相关阅读:
    图片保持比例居中显示
    登录后跳转到登录前的页面
    如何为网站添加百度统计功能
    项目更新到公网服务器的操作步骤
    jQuery Mobile中表单的使用体会
    手机端静态网页制作需要注意的几个问题
    bootstrap分页插件的使用
    Dell7040mt安装win7系统说明
    linux静态ip的设置
    eclipse项目有红叉的解决办法
  • 原文地址:https://www.cnblogs.com/zfyouxi/p/5398733.html
Copyright © 2011-2022 走看看