zoukankan      html  css  js  c++  java
  • hdu-5635 LCP Array

    LCP Array

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 358    Accepted Submission(s): 102


    Problem Description
    Peter has a string s=s1s2...sn, let suffi=sisi+1...sn be the suffix start with i-th character of s. Peter knows the lcp (longest common prefix) of each two adjacent suffixes which denotes as ai=lcp(suffi,suffi+1)(1i<n).

    Given the lcp array, Peter wants to know how many strings containing lowercase English letters only will satisfy the lcp array. The answer may be too large, just print it modulo 109+7.
     
    Input
    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer n (2n10^5) -- the length of the string. The second line contains n1 integers: a1,a2,...,an1 (0ain).

    The sum of values of n in all test cases doesn't exceed 10^6.
     
    Output
    For each test case output one integer denoting the answer. The answer must be printed modulo 1e9+7.
     
    Sample Input
    3
    3
    0 0
    4
    3 2 1
    3
    1 2
     
    Sample Output
    16250
    26
    0
    AC代码:

    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    const int N=1e5+5;
    const long long mod=1e9+7;
    int n,a[N];
    int main()
    {
    int T;
    scanf("%d",&T);
    while(T--)
    {
    scanf("%d",&n);
    for(int i=1;i<n;i++)
    {
    scanf("%d",&a[i]);
    }
    a[n]=0;
    int flag=1;
    for(int i=1;i<n;i++)
    {
    if(a[i])
    {
    if(a[i]-a[i+1]!=1)
    {
    flag=0;
    break;
    }
    }
    }
    if(!flag)
    {
    cout<<"0"<<" ";
    }
    else
    {
    int num=0;
    for(int i=1;i<n;i++)
    {
    if(!a[i])
    {
    num++;
    }
    }
    long long ans=26;
    for(int i=0;i<num;i++)
    {
    ans=(ans*25)%mod;
    }
    cout<<ans%mod<<" ";
    }

    }
    return 0;
    }

     
  • 相关阅读:
    MSN无法登录(错误代码80072745)的解决方法
    C#3.0新体验(二) 扩展方法
    My DreamTech
    让IE崩溃的bug, IE8也一样崩溃
    多线程的相关概念
    10条PHP经验总结
    PHP框架 CI与TP之MVC比较
    多线程设计要点
    Linux yum命令的使用技巧
    BigPipe 的工作原理
  • 原文地址:https://www.cnblogs.com/zhangchengc919/p/5246287.html
Copyright © 2011-2022 走看看