zoukankan      html  css  js  c++  java
  • hdu-1025 Constructing Roads In JGShining's Kingdom(二分查找)

    题目链接:

    Constructing Roads In JGShining's Kingdom

    Time Limit: 2000/1000 MS (Java/Others)    

    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 21045    Accepted Submission(s): 5950


    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

    For example, the roads in Figure I are forbidden.



    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     
    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     
    Output
    For each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
     
    Sample Input
    2
    1 2
    2 1
    3
    1 2
    2 3
    3 1
     
    Sample Output
    Case 1:
    My king, at most 1 road can be built.
    Case 2:
    My king, at most 2 roads can be built.
    Hint
    Huge input, scanf is recommended.

     题意:给你两个条线上一对一对的点,要把这一对一对的点连接起来,且连线不能相交,问最多有多少条线;

     思路:按其中的一组数的大小排序,然后另一列数的最长上升子序列的长度就是答案,然后用一个O(n*logn)的算法找到这个长度,O(n^2)的方法会超时;

    AC代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <stack>
    #include <algorithm>
    using namespace std;
    const int N=5e5+3;
    int ans[N];
    struct node
    {
        int a,b;
    };
    node x[N];
    int cmp(node c,node d)
    {
       // if(c.a==d.a)return c.b<d.b;
        return c.a<d.a;
    }
    stack<int>s;
    int main()
    {
        int n;
        int cnt=1;
        while(scanf("%d",&n)!=EOF)
        {
            for(int i=1;i<=n;i++)
            {
                scanf("%d%d",&x[i].a,&x[i].b);
            }
            sort(x+1,x+n+1,cmp);
            int num=1;
            ans[1]=x[1].b;
            for(int j=2;j<=n;j++)
            {
                if(x[j].b>ans[num])
                {
                    num++;
                    ans[num]=x[j].b;
                }
                else
                {
                    int pos=upper_bound(ans+1,ans+num+1,x[j].b)-ans;
                    ans[pos]=x[j].b;
                }
    
            }
               if(num==1) printf("Case %d:
    My king, at most %d road can be built.
    
    ",cnt++,num);
            else printf("Case %d:
    My king, at most %d roads can be built.
    
    ",cnt++,num);
        }
        return 0;
    }
  • 相关阅读:
    【转载自酷壳】编程能力与编程年龄
    xcode中的nslog数据格式
    xcode 的 pch 预编译头文件
    获取App的Documents路径
    使用gdb调试app
    收集的一些OC知识点
    收集到的几篇看雪学院文章
    【转】iOS平台的应用程序调试与分析
    前端技术开发的一些建议
    UIImage的两种加载方式
  • 原文地址:https://www.cnblogs.com/zhangchengc919/p/5293649.html
Copyright © 2011-2022 走看看