zoukankan      html  css  js  c++  java
  • 1019 General Palindromic Number

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0N > 0N>0 in base b≥2b ge 2b2, where it is written in standard notation with k+1k+1k+1 digits aia_iai​​ as ∑i=0k(aibi)sum_{i=0}^k (a_ib^i)i=0k​​(ai​​bi​​). Here, as usual, 0≤ai<b0 le a_i < b0ai​​<b for all iii and aka_kak​​ is non-zero. Then NNN is palindromic if and only if ai=ak−ia_i = a_{k-i}ai​​=aki​​ for all iii. Zero is written 0 in any base and is also palindromic by definition.

    Given any positive decimal integer NNN and a base bbb, you are supposed to tell if NNN is a palindromic number in base bbb.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers NNN and bbb, where 0<N≤1090 < N le 10^90<N109​​ is the decimal number and 2≤b≤1092 le b le 10^92b109​​ is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line Yes if NNN is a palindromic number in base bbb, or No if not. Then in the next line, print NNN as the number in base bbb in the form "aka_kak​​ak−1a_{k-1}ak1​​ ... a0a_0a0​​". Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    

    Sample Output 1:

    Yes
    1 1 0 1 1
    

    Sample Input 2:

    121 5
    

    Sample Output 2:

    No
    4 4 1
    注意:
      数组不能开过大,否则在本机上能够正常运行,提交后会提示编译错误
    #include<iostream>
    #include<sstream>
    #include<algorithm>
    #include<map>
    #include<cmath>
    #include<cstdio>
    #include<string.h>
    #include<queue>
    #include<vector>
    using namespace std;
    int a[100000000];
    int i=0;
    void toBase(long long int n,int base)
    {
        long long int temp;
        while(n!=0)
        {
            a[i]=n%base;
            n/=base;
            i++;
        }
    }
    int main()
    {
        long long int n;
        cin>>n;
        int base;
        cin>>base;
    
        toBase(n,base);
        int j=i-1;
        for(int t=0; t<i; t++,j--)
        {
            if(a[t]!=a[j])
                break;
    
        }
    
        if(j==-1)
        {
            cout<<"Yes"<<endl;
            if(i>0)
                cout<<a[0];
            for(int t=1; t<i; t++)
                cout<<" "<<a[t];
        }
        else
        {
            cout<<"No"<<endl;
            cout<<a[i-1];
            for(int t=i-2; t>=0; t--)
                cout<<" "<<a[t];
    
    
        }
        return 0;
    }
     
  • 相关阅读:
    系统综合实践_5
    系统综合实践_4
    系统综合实践_3
    系统综合实践_2
    系统综合实践_1
    软件工程17—第09组 Beta版本演示
    软件工程16—第09组 Beta冲刺(4/4)
    软工实践个人总结
    第06组 Beta版本演示
    第06组 Beta冲刺(5/5)
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10228790.html
Copyright © 2011-2022 走看看