zoukankan      html  css  js  c++  java
  • 1155 Heap Paths (30 分)判断是否是一个堆

    1155 Heap Paths (30 分)

    In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

    One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

    Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (1<N1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

    Output Specification:

    For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

    Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

    Sample Input 1:

    8
    98 72 86 60 65 12 23 50
    

    Sample Output 1:

    98 86 23
    98 86 12
    98 72 65
    98 72 60 50
    Max Heap
    

    Sample Input 2:

    8
    8 38 25 58 52 82 70 60
    

    Sample Output 2:

    8 25 70
    8 25 82
    8 38 52
    8 38 58 60
    Min Heap
    

    Sample Input 3:

    8
    10 28 15 12 34 9 8 56
    

    Sample Output 3:

    10 15 8
    10 15 9
    10 28 34
    10 28 12 56
    Not Heap

    思路:
      1、由于输入是层序遍历,且是完全二叉树,所以使用一个数组存储树,根节点下标为1,这样i是根节点,2*i是左孩子,2*i+1是
    右孩子。然后按照先右子树再左子树的顺序遍历树,并且存储遍历路径,当遇到叶子结点时候输出。
      2、由于题目中给出的结点数目N满足1<N<=1,000,所以在遍历之前先使用第一个结点和第二个结点进行比较,做一个预判断,根据判断
    结果,假设其为max heap或者min heap。再输出路径的时候再判断与假设是否一致即可,详情请看代码。
      
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    using namespace std;
    bool flag=true;
    vector<int> path;
    //对树进行深度遍历
    void print(int tree[],int i,int n,bool isBig)
    {
        //cout<<i<<" ";
        path.push_back(tree[i]);
        //cout<<tree[i]<<endl;
        if(2*i>n)
        {
            if(isBig)
            {
                // cout<<endl;
                if(path.size()>0)
                    cout<<path[0];
                for(int j=1; j<path.size(); j++)
                {
                    if(path[j]>path[j-1])
                        flag=false;
                    cout<<" "<<path[j];
                }
                cout<<endl;
    
            }
            else
            {
                if(path.size()>0)
                    cout<<path[0];
                for(int j=1; j<path.size(); j++)
                {
                    if(path[j]<path[j-1])
                        flag=false;
                    cout<<" "<<path[j];
                }
                cout<<endl;
            }
            return;
        }
        if(2*i+1<=n)
        {
            print(tree,2*i+1,n,isBig);
            path.pop_back();
        }
        if(2*i<=n)
        {
            print(tree,2*i,n,isBig);
            path.pop_back();
        }
    }
    
    
    
    
    int main()
    {
        int n;
        scanf("%d",&n);
        int tree[n+1];
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&tree[i]);
            // cout<<tree[i]<<endl;
        }
        // path.push_back(tree[1]);
        if(tree[1]<tree[2])//如果是min heap,则父节点小
        {
            print(tree,1,n,false);
            if(flag)
                cout<<"Min Heap"<<endl;
            else
                cout<<"Not Heap"<<endl;
        }
        else
        {
            print(tree,1,n,true);
            if(flag)
                cout<<"Max Heap"<<endl;
            else
                cout<<"Not Heap"<<endl;
        }
    
        return 0;
    }
     
  • 相关阅读:
    Pytorch学习笔记14----torch中相关函数使用:view函数、max()函数、squeeze()函数
    Pytorch学习笔记13----LSTM+CRF模型的CRF层原理与代码理解
    Pytorch学习笔记12----损失函数nn.CrossEntropyLoss()、nn.NLLLoss()
    Pytorch学习笔记12---- Pytorch的LSTM的理解及入门小案例
    Pytorch学习笔记11----model.train()与model.eval()的用法、Dropout原理、relu,sigmiod,tanh激活函数、nn.Linear浅析、输出整个tensor的方法
    Pytorch学习笔记10----LSTM循环神经网络原理
    webpack入门
    js判断对象是否为空对象的几种方法
    js的防抖和节流
    简述http协议
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10301006.html
Copyright © 2011-2022 走看看