zoukankan      html  css  js  c++  java
  • 1140 Look-and-say Sequence (20 分)简单模拟

    1140 Look-and-say Sequence (20 分)

    Look-and-say sequence is a sequence of integers as the following:

    D, D1, D111, D113, D11231, D112213111, ...
    

    where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

    Input Specification:

    Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

    Output Specification:

    Print in a line the Nth number in a look-and-say sequence of D.

    Sample Input:

    1 8
    

    Sample Output:

    1123123111
    思路
      为了求第n+1个,要对第n个进行遍历。对于每一个遍历到的数字,首先把该数字保存,然后计数该数字连续相同的个数。
    把个数也保存当这个遍历结束的时候,第n+1个就求出来了。
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    #include<stack>
    using namespace std;
    
    
    int main()
    {
        int d,n;
        cin>>d>>n;
        vector<int> temp;
        temp.push_back(d);
        vector<int>print;
        for(int i=0;i<n-1;i++)
        {
            for(int j=0;j<temp.size();)
            {
                int m=j,coun=0;
                print.push_back(temp[j]);
                while(m<temp.size())
                {
                    if(temp[m]==temp[j])
                    {
                        m++;
                        coun++;
                    }
                    else
                        break;
                }
                j=m;
                print.push_back(coun);
            }
            temp=print;
            print.clear();
        }
        print=temp;
        for(auto it:print)
            cout<<it;
        return 0;
    }



  • 相关阅读:
    异常:调用链顺序
    日志分割建议
    java异常处理规范
    忽略字母大小写情况下统计字符出现的次数
    十六进制转化为十进制
    搜索(剪枝优化):HDU 5113 Black And White
    水题:HDU 5112 A Curious Matt
    综合(奇技淫巧):HDU 5118 GRE Words Once More!
    网络流(费用流)CodeForces 321B:Ciel and Duel
    数学(概率)CodeForces 626D:Jerry's Protest
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10315158.html
Copyright © 2011-2022 走看看