zoukankan      html  css  js  c++  java
  • 1036 Boys vs Girls (25 分)

    1036 Boys vs Girls (25 分)

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​​gradeM​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    #include<stack>
    #include<string.h>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    struct Student
    {
        string name;
        string id;
        int grade;
    };
    bool cmp(Student&A,Student&B)
    {
        return A.grade<B.grade;
    }
    
    
    
    int main()
    {
        int n;
        cin>>n;
        vector<Student> males,females;
        Student temp;
        char sex;
        for(int i=0;i<n;i++)
        {
            cin>>temp.name>>sex>>temp.id>>temp.grade;
            if(sex=='M')
                males.push_back(temp);
            else
                females.push_back(temp);
        }
        sort(males.begin(),males.end(),cmp);
        sort(females.begin(),females.end(),cmp);
        bool flag=false;
        if(females.size()==0)
        {
            cout<<"Absent"<<endl;
            flag=true;
        }
        else
            cout<<females[females.size()-1].name<<" "<<females[females.size()-1].id<<endl;
        if(males.size()==0)
        {
            cout<<"Absent"<<endl;
            flag=true;
        }
        else
            cout<<males[0].name<<" "<<males[0].id<<endl;
        if(flag)
            cout<<"NA"<<endl;
        else
            cout<<females[females.size()-1].grade-males[0].grade<<endl;
        return 0;
    }

      
  • 相关阅读:
    Mac使用笔记(二)
    AJAX tooltip by jQuery UI Widget and MVC3
    MVC4的bundling功能简介
    Mac使用笔记
    浅析ASP.Net Web API的Formatter
    浅析ASP.net Web API的Model验证(使用MVC4框架的Web API须谨慎)
    2012年读过的最好的书
    SQLite在.net下的使用方法
    C#也允许函数默认参数
    chrome不支持对opener方法的调用?
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10324667.html
Copyright © 2011-2022 走看看