zoukankan      html  css  js  c++  java
  • 1042 Shuffling Machine (20 分)简单模拟

    1042 Shuffling Machine (20 分)

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, 
    H1, H2, ..., H13, 
    C1, C2, ..., C13, 
    D1, D2, ..., D13, 
    J1, J2
    

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<map>
    #include<set>
    #include<cmath>
    #include<climits>
    #include<sstream>
    #include<cstdio>
    #include<string.h>
    using namespace std;
    
    struct Node
    {
        int index;
        string code;
        string exchange;
    };
    
    
    int main()
    {
        Node node[55];
        for(int i=1; i<5; i++)
        {
            for(int j=1; j<14; j++)
            {
                if(i==1)
                {
                    node[j]= {j,"S"+to_string(j)};
                }
                else if(i==2)
                    node[(i-1)*13+j]= {j,"H"+to_string(j)};
                else if(i==3)
                    node[(i-1)*13+j]= {j,"C"+to_string(j)};
                else
                    node[(i-1)*13+j]= {j,"D"+to_string(j)};
            }
        }
        node[53]= {53,"J1"};
        node[54]= {54,"J2"};
        int n;
        scanf("%d",&n);
        int a[55];
        for(int i=1; i<55; i++)
            scanf("%d",&a[i]);
    
        for(int i=0; i<n; i++)
        {
            for(int j=1; j<55; j++)
            {
                node[a[j]].exchange=node[j].code;
            }
            for(int j=1; j<55; j++)
            {
                node[j].code=node[j].exchange;
            }
    
        }
        cout<<node[1].exchange;
        for(int i=2; i<55; i++)
            cout<<" "<<node[i].exchange;
        return 0;
    }
  • 相关阅读:
    PHP审计之POP链挖掘
    PHP审计之PHP反序列化漏洞
    Centos虚拟机IP配置以及Tenginx安装部署
    VMware下载安装与CentOS虚拟机安装
    重学c#系列——list(十二)
    整理k8s————k8s prod相关[三]
    重学c#系列——字典(十一)
    整理k8s————k8s组件[二]
    整理k8s————k8s概念[一]
    mysql 必知必会整理—数据库的维护[十八]
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10341611.html
Copyright © 2011-2022 走看看