zoukankan      html  css  js  c++  java
  • nyoj 42 一笔画问题

    一笔画问题

    时间限制:3000 ms  |  内存限制:65535 KB

    难度:4

    描述

    zyc从小就比较喜欢玩一些小游戏,其中就包括画一笔画,他想请你帮他写一个程序,判断一个图是否能够用一笔画下来。

    规定,所有的边都只能画一次,不能重复画。

     

    输入

    第一行只有一个正整数N(N<=10)表示测试数据的组数。
    每组测试数据的第一行有两个正整数P,Q(P<=1000,Q<=2000),分别表示这个画中有多少个顶点和多少条连线。(点的编号从1到P)
    随后的Q行,每行有两个正整数A,B(0<A,B<P),表示编号为A和B的两点之间有连线。

    输出

    如果存在符合条件的连线,则输出"Yes",
    如果不存在符合条件的连线,输出"No"。

    样例输入

    2

    4 3

    1 2

    1 3

    1 4

    4 5

    1 2

    2 3

    1 3

    1 4

    3 4

    样例输出

    No

    Yes

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    using namespace std;             
    int father[5001];                   
    int rank[5001];     
    
    int find(int x)                 
    {
        if(x!=father[x])                    
        {
            father[x]=find(father[x]);      
        }
        return father[x];
    }
    void union_xy(int x,int y)               
    {
        x=find(x);                                
        y=find(y);
        if(x==y) return ;
        if(rank[x]>rank[y])
        {
            father[y]=x;                        
            rank[x]++;
        }
        else
        {
            if(rank[x]==rank[y])
            {
                rank[y]++;
            }
            father[x]=y;
        }
    }
    int main()
    {
        int ncases,n,m,i,x,y,degree[5001];
        scanf("%d",&ncases);
        while(ncases--)
        {
            memset(degree,0,sizeof(degree));
            cin>>n>>m;
            for(i=1;i<=n;i++)
            {
                father[i]=i;                      
                rank[i]=0;
            }
            int sum=0,count=0;
            while(m--)
            {
                scanf("%d%d",&x,&y);
                degree[x]++;                      
                degree[y]++;
                x=find(x); 
                y=find(y);
    
    
                if(x!=y)
                {
                    union_xy(x,y);
                }
            }
            for(i=1;i<=n;i++)
            {
                if(find(i)==i)              
    
                {
                    count++;                     
                }
                if(degree[i]%2==1)                
                {
                    sum++;
                }
            }
            if((sum==0||sum==2)&&count==1)         
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
        }
    }        
    

      

  • 相关阅读:
    转载:MyBatis获取插入记录的自增长字段值
    006---抽象类
    005---组合
    004---继承与派生
    003---属性查找和绑定方法
    002---类与对象
    001---面向对象和面向过程的区别
    017---Django的中间件解决跨域
    10---git安装
    007---归并排序
  • 原文地址:https://www.cnblogs.com/zhangliu/p/7053288.html
Copyright © 2011-2022 走看看