zoukankan      html  css  js  c++  java
  • Hdu 1040 As Easy As A+B

    As Easy As A+B

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 62502    Accepted Submission(s): 26869

    Problem Description

    These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
    Give you some integers, your task is to sort these number ascending (升序).
    You should know how easy the problem is now!
    Good luck!

    Input

    Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
    It is guarantied that all integers are in the range of 32-int.

    Output

    For each case, print the sorting result, and one line one case.

    Sample Input

    2

    3 2 1 3

    9 1 4 7 2 5 8 3 6 9

    Sample Output

    1 2 3

    1 2 3 4 5 6 7 8 9

    #include<stdio.h>
    #include<algorithm>using namespace std;
     
    int main()
    {
           int a[1000];
           int N,n;
           scanf("%d",&N);
           while(N--)
           {
             scanf("%d",&n);
         for(int i=0;i<n;++i)    
         {
             scanf("%d",&a[i]);
        }
      sort(a,a+n);   
     for(int i=0;i<n;i++)  
      {
           printf(i<n-1?"%d ":"%d
    ",a[i]);  
    }
    }
    return 0;
    }
    

      

  • 相关阅读:
    Commander Nodejs 命令行接口
    数据库集群 ---续集
    数据库集群
    实时查看linux下的日志
    自动化测试
    python中list和dict
    super与this的用法
    数据类型
    父类调用子类方法
    子类调用父类方法
  • 原文地址:https://www.cnblogs.com/zhangliu/p/7057823.html
Copyright © 2011-2022 走看看