zoukankan      html  css  js  c++  java
  • POJ1258:Agri-Net(最小生成树模板题)

    http://poj.org/problem?id=1258

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28

    题目大意:有n个农场,已知这n个农场都互相相通,有一定的距离,现在每个农场需要装光纤,问怎么安装光纤能将所有农场都连通起来,并且要使光纤距离最小,输出安装光纤的总距离
    解题思路:又是一个最小生成树,因为给出了一个二维矩阵代表他们的距离,直接算prim就行了。
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #define INF 0x3f3f3f3f
    using namespace std;
    int map[101][101];
    int n,dis[101],v[101];
    void prim()
    {
        int min,sum=0,k;
        for(int i=1; i<=n; i++)
        {
            v[i]=0;
            dis[i]=INF;
        }
        for(int i=1; i<=n; i++)
            dis[i]=map[1][i];
        v[1]=1;
        for(int j=1; j<n; j++)
        {
            min=INF;
            for(int i=1; i<=n; i++)
            {
                if(v[i]==0&&dis[i]<min)
                {
                    k=i;
                    min=dis[i];
                }
            }
            sum+=min;
            v[k]=1;
            for(int i=1; i<=n; i++)
            {
                if(v[i]==0&&map[k][i]<dis[i])
                {
                    dis[i]=map[k][i];
                }
            }
        }
        cout<<sum<<endl;
    }
    int main()
    {
        while(scanf("%d",&n)!=EOF)
        {
            if(n==0) break;
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<=n; j++)
                {
                    cin>>map[i][j];
                }
            }
            prim();
        }
        return 0;
    }


  • 相关阅读:
    微信小程序常用的方法(留着用)
    微信小程序H5预览页面框架(二维码不隐藏)
    微信小程序H5预览页面框架
    关于微信小程序的一点经验
    微信小程序修改单选按钮的默认样式
    Tomcat8升级后URL中特殊字符报错出现原因
    线程的生命周期和状态控制
    多线程相关概率解释
    多线程面试题集锦三
    spring的xml文件的作用与实现原理
  • 原文地址:https://www.cnblogs.com/zhangmingcheng/p/3968947.html
Copyright © 2011-2022 走看看