zoukankan      html  css  js  c++  java
  • HDU:Gauss Fibonacci(矩阵快速幂+二分)

    http://acm.hdu.edu.cn/showproblem.php?pid=1588

    Problem Description
    Without expecting, Angel replied quickly.She says: "I'v heard that you'r a very clever boy. So if you wanna me be your GF, you should solve the problem called GF~. " How good an opportunity that Gardon can not give up! The "Problem GF" told by Angel is actually "Gauss Fibonacci". As we know ,Gauss is the famous mathematician who worked out the sum from 1 to 100 very quickly, and Fibonacci is the crazy man who invented some numbers.
    Arithmetic progression: g(i)=k*i+b; We assume k and b are both non-nagetive integers.
    Fibonacci Numbers: f(0)=0 f(1)=1 f(n)=f(n-1)+f(n-2) (n>=2)
    The Gauss Fibonacci problem is described as follows: Given k,b,n ,calculate the sum of every f(g(i)) for 0<=i<n The answer may be very large, so you should divide this answer by M and just output the remainder instead.
     
    Input
    The input contains serveral lines. For each line there are four non-nagetive integers: k,b,n,M Each of them will not exceed 1,000,000,000.
     
    Output
    For each line input, out the value described above.
     
    Sample Input
    2 1 4 100
    2 0 4 100
     
    Sample Output
    21 12
     

    题目解析:

    用于构造斐波那契的矩阵为

    0,1

    1,1

    设这个矩阵为A。

    sum=f(b)+f(k+b)+f(2*k+b)+f(3*k+b)+........+f((n-1)*k+b)

    <=>sum=A^b+A^(k+b)+A^(2*k+b)+A^(3*k+b)+........+A^((n-1)*k+b)

    <=>sum=A^b+A^b*(A^k+A^2*k+A^3*k+.......+A^((n-1)*k))(1)

    设矩阵B为A^k;

    那么(1)式为

    sum=A^b+A^b*(B+B^2+B^3+......+B^(n-1));

    显然,这时候就可以用二分矩阵做了,括号内的就跟POJ 3233的形式一样了。

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <queue>
    #include <stack>
    #define inf 0x3f3f3f3f
    #define LL __int64//int就WA了
    using namespace std;
    struct ma
    {
        LL a[2][2];
    } init,res,B,C;
    int mod,k,b,n,K;
    void Init()
    {
        init.a[0][0]=0;
        init.a[0][1]=1;
        init.a[1][0]=1;
        init.a[1][1]=1;
    }
    ma Mult(ma x,ma y)
    {
        ma tmp;
        for(int i=0; i<2; i++)
        {
            for(int j=0; j<2; j++)
            {
                tmp.a[i][j]=0;
                for(int z=0; z<2; z++)
                {
                    tmp.a[i][j]=(tmp.a[i][j]+x.a[i][z]*y.a[z][j])%mod;
                }
            }
        }
        return tmp;
    }
    ma Pow(ma x,int K)
    {
        ma tmp;
        for(int i=0; i<2; i++)
        {
            for(int j=0; j<2; j++)
                tmp.a[i][j]=(i==j);
        }
        while(K!=0)
        {
            if(K&1)
                tmp=Mult(tmp,x);
            K>>=1;
            x=Mult(x,x);
        }
        return tmp;
    }
    ma Add(ma x,ma y)
    {
        ma tmp;
        for(int i=0; i<2; i++)
        {
            for(int j=0; j<2; j++)
            {
                tmp.a[i][j]=(x.a[i][j]+y.a[i][j])%mod;
            }
        }
        return tmp;
    }
    ma Sum(ma x,int K)
    {
        ma tmp,y;
        if(K==1)
            return x;
        tmp=Sum(x,K/2);
        if(K&1)
        {
            y=Pow(x,K/2+1);
            tmp=Add(Mult(y,tmp),tmp);
            tmp=Add(tmp,y);
        }
        else
        {
            y=Pow(x,K/2);
            tmp=Add(Mult(y,tmp),tmp);
        }
        return tmp;
    }
    /*另外一种写法
    matrix Sum(matrix x, int k) 

        if(k==1) return x; 
        if(k&1) 
            return Add(Sum(x,k-1),Pow(x,k));  //如果k是奇数,求x^k+sum(x,k-1)
        matrix tmp; 
        tmp=Sum(x,k>>1); 
        return Add(tmp,Mult(tmp,Pow(x,k>>1))); 
    }

    */
    int main() { while(scanf("%d%d%d%d",&k,&b,&n,&mod)!=EOF) { Init(); B=Pow(init,k); C=Pow(init,b); res=Sum(B,n-1); res=Mult(C,res); res=Add(C,res); printf("%I64d ",res.a[1][0]); } return 0; }
  • 相关阅读:
    Python 遍历文件 读取文件夹里面的所有文件
    生活 帝国霸略 辅助工具的实现
    生活 帝国霸略 更换账户登陆 电脑登陆iphone手机账户 电脑手机同步登陆
    Python 颜色检测
    Python 指定窗口截屏
    Python 图片裁剪
    Python 窗口查找
    ES5新增的数组方法
    ES5对象新增的方法
    谈谈对文档碎片的理解
  • 原文地址:https://www.cnblogs.com/zhangmingcheng/p/4133896.html
Copyright © 2011-2022 走看看