zoukankan      html  css  js  c++  java
  • Uva

    Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

    Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes arelative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

    Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

    Input

    Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

    Output

    Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

    Sample input

    ladder came tape soon leader acme RIDE lone Dreis peat
     ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
    noel dire Disk mace Rob dries
    #

    Sample output

    Disk
    NotE
    derail
    drIed
    eye
    ladder
    soon

    AC代码:

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cctype>
    #include <cstring>
    #include <string>
    #include <sstream>
    #include <vector>
    #include <set>
    #include <map>
    #include <algorithm>
    
    using namespace std;
    
    map<string, int> cnt;
    vector<string> words;
    
    string repr(const string& s) 
    {
    	string ans = s;
    	for (int i = 0; i < ans.length(); i++) {
    		ans[i] = tolower(ans[i]);
    	}
    	sort(ans.begin(), ans.end());
    	return ans;
    }
    
    int main()
    {
    	int n = 0;
    	string s;
    	while (cin >> s) {
    		if (s[0] == '#') {
    			break;
    		}
    		words.push_back(s);
    		string r = repr(s);
    		if (!cnt.count(r)) {
    			cnt[r] = 0;
    		}
    		cnt[r]++;
    	}
    	vector<string> ans;
    	for (int i = 0; i < words.size(); i++) {
    		if (cnt[repr(words[i])] == 1) {
    			ans.push_back(words[i]);
    		}
    	}
    	sort(ans.begin(), ans.end());
    	for (int i = 0; i < ans.size(); i++) {
    		cout << ans[i] << endl;
    	}
    
    	return 0;
    }




  • 相关阅读:
    ORACLE之ora01722和ORA01403的错误测试
    数据库事务的简单学习(一)
    oracle在线重定义(一)
    数据库拆表拆库的常用策略和PL/SQL代码经验谈(zt)
    如何杀掉Oracle的Session
    异步电机参数辨识
    如何下载专利
    电涡流测功机
    Matlab/Simulink 环境下的车用永磁电机系统仿真
    基本放大器电路,希望对各位有用。[转]
  • 原文地址:https://www.cnblogs.com/zhangyaoqi/p/4591601.html
Copyright © 2011-2022 走看看