zoukankan      html  css  js  c++  java
  • Uva

    A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown -- an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings.

    The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h . Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).

    epsfbox{p3712a.eps}

    There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.

    epsfbox{p3712b.eps}

    The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to find the minimal length of the stripe which is enough for cutting both sections simultaneously.

    Input 

    The input file contains several test cases, each of them as described below.

    There are two lines in the input, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit -- 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated.

    Each string is non-empty and its length does not exceed 100.

    Output 

    For each test case, write to the output a line containing a single integer number -- the minimal length of the stripe required to cut off given sections.

    Sample Input 

    2112112112 
    2212112 
    12121212 
    21212121 
    2211221122 
    21212
    

    Sample Output 

    10 
    8 
    15

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    
    bool test(int k, char s1[], char s2[]){
    	for (int i = 0; s1[k + i] && s2[i]; i++){
    		if (s1[k + i] + s2[i] - 2 * '0' > 3)return false;
    	}
    	return true;
    }
    
    int fun(char s1[], char s2[]){
    	int k = 0;
    	while (!test(k, s1, s2)) {
    		k++;
    	}
    	return max(strlen(s1), strlen(s2) + k);
    }
    
    int main(){
    	char bottom[105], top[105];
    	while (scanf("%s%s", bottom, top) != EOF)//对称性
    		cout << min(fun(bottom, top), fun(top, bottom)) << endl;
    	return 0;
    }


    AC代码:


  • 相关阅读:
    人工智能第一次作业
    在uni-app的textarea中输入纯数字或者英文不换行的问题
    uni-app实现选择图片上传并显示进度条
    减肥计划
    前端时间格式2020-02-11T12:24:18.000+0000转化成正常格式
    男孩和女孩
    java 获取当前年份 月份 日期
    深海收破烂
    如何爱一个人
    随手心情
  • 原文地址:https://www.cnblogs.com/zhangyaoqi/p/4591618.html
Copyright © 2011-2022 走看看