zoukankan      html  css  js  c++  java
  • NYOJ72Financial Management

    Financial Management

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:1
     
    描述
    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
     
    输入
    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included. 
    输出
    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output. 
    样例输入
    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75
    
    样例输出
    1581.42
    View Code
     
    #include <stdio.h>
    int main()
    {
        int i;
        float sum=0.0,x;
        for(i=0;i<12;i++)
        {
            scanf("%f",&x);
            sum+=x;
        }
        printf("%.2f\n",sum/12);
        return 0;
    }
        
            
  • 相关阅读:
    [CF703D] Mishka and Interesting sum
    [CF1454F] Array Partition
    [CF13E] Holes
    [CF1110D] Jongmah
    [CF1204D2] Kirk and a Binary String
    [CF936B] Sleepy Game
    [CF546E] Soldier and Traveling
    [CF1025D] Recovering BST
    [CF598C] Nearest vectors
    [CF988E] Divisibility by 25
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_06_040000.html
Copyright © 2011-2022 走看看