zoukankan      html  css  js  c++  java
  • NYOJ72Financial Management

    Financial Management

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:1
     
    描述
    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
     
    输入
    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included. 
    输出
    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output. 
    样例输入
    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75
    
    样例输出
    1581.42
    View Code
     
    #include <stdio.h>
    int main()
    {
        int i;
        float sum=0.0,x;
        for(i=0;i<12;i++)
        {
            scanf("%f",&x);
            sum+=x;
        }
        printf("%.2f\n",sum/12);
        return 0;
    }
        
            
  • 相关阅读:
    java--io流之转换流
    java--IO流之字节流、字符流
    java--递归
    java--IO流之File类
    java --JDBC
    2018-09-15JDBC事务详解1
    2018-09-10JSP内容和标签的查看权限+9个内置对象
    2018-09-12DBUtils工具包+DBCP连接池
    2018-09-08Cookie的发送和Cookie的读取+Session基本原理
    参考博客:URI和URL的区别
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_06_040000.html
Copyright © 2011-2022 走看看