zoukankan      html  css  js  c++  java
  • nyoj5 Binary String Matching

    Binary String Matching

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:3
     
    描述
    Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
     
    输入
    The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
    输出
    For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
    样例输入
    3
    11
    1001110110
    101
    110010010010001
    1010
    110100010101011 
    样例输出
    3
    0
    3 
    View Code
     
    #include<stdio.h>
    #include<string.h>
    #define maxn 1000+10
    char strb[maxn];
    char stra[11];
    int main()
    {
        int n,i,count,j,lena,lenb,k;
        scanf("%d",&n);
        getchar();
        while(n--)
        {
            scanf("%s",stra);
            scanf("%s",strb);
            lena=strlen(stra);
            lenb=strlen(strb);
            count=0;j=0;
            for(i=0;i<lenb;i++)
            {j=0;k=i;
                while(1&&j<lena)
                {
                if(stra[j]!=strb[k])
                    break;
                j++;k++;
                }
                if(j==lena)
                    count++;
            }
            printf("%d\n",count);
        }
        return 0;
    }
    
    
            
  • 相关阅读:
    arm-linux-gcc-4.5.1的安装…
    OK6410之tftp下载内核,nfs…
    非常详细的ok6410的linux系统移植…
    2009-2010网络最热的&nbsp;嵌入式…
    Vue-基础(二)
    【SpringBoot】Springboot1.5.9整合WebSocket
    Hadoop本地环境安装
    Vue-基础(一)
    【Jwt】JSON Web Token
    【JDK8】Java8 新增BASE64加解密API
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_07_110.html
Copyright © 2011-2022 走看看