zoukankan      html  css  js  c++  java
  • hide handkerchief


    Problem Description
    The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
    Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
    Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
    So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
     

    Input
    There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
     

    Output
    For each input case, you should only the result that Haha can find the handkerchief or not.
     

    Sample Input
    3 2
    -1 -1
     

    Sample Output
    YES
     

    当从m开始找时,如果m与n有公约数时,在找盒子时,就只会在这些约数的倍数之间找,而不是约数倍数的盒子就永远也不会被找到,所以当m与n的最大公约数为1,即m与n互质时才能找遍所有的盒子。

    (一)

    #include<stdio.h>
    #include<math.h>
    int Zhisu(int a,int b)
    {
        if((a-b)==0)
            return b;
        else
            Zhisu(b,abs(a-b));
    }
    void main()
    {
        int a,b;
        scanf("%d %d",&a,&b);
        while(a!=-1 && b!=-1)
        {
            if(Zhisu(a,b)==1)
                printf("YES ");
            else
                printf("POOR Haha ");
            scanf("%d %d",&a,&b);
        }
    }

    (二)

    #include<stdio.h>
    void main()
    {
        int a,b,c;
        while(1)
        {
            scanf("%d %d",&a,&b);
            if(a==-1 && b==-1)
                return;
            while(b!=0)
            {
                c=a%b;
                a=b;
                b=c;
            }
            if(a==1)
                printf("YES ");
            else
                printf("POOR Haha ");
        }
    }

  • 相关阅读:
    OC学习小总结
    导航控制器
    稍微完善了一些的简单计算器的设计
    android端腾讯性能监控框架Matrix源码分析之第一篇
    android MVP模式介绍与实战
    android声音检测仪---分贝仪 (附源码)
    我的几个开源项目
    结合支付宝和微信首页巩固android事件分发机制 (附项目源码)
    SLAM论文阅读笔记
    Python之可迭代对象、迭代器、生成器
  • 原文地址:https://www.cnblogs.com/zhaoxinshanwei/p/3499357.html
Copyright © 2011-2022 走看看