zoukankan      html  css  js  c++  java
  • Accepted Necklace

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2380    Accepted Submission(s): 927


    Problem Description
    I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
     
    Input
    The first line of input is the number of cases.
    For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
    Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
    The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.
     
    Output
    For each case, output the highest possible value of the necklace.
     
    Sample Input
    1 2 1 1 1 1 1 3
     
    Sample Output
    1
     
     
    为为为为为什么老是超时啊 啊 啊啊啊。。。
    #include<iostream>
    using namespace std;
    typedef struct
    {
        int w;
        int v;
    }Var;
    int max_v=0;
    Var var[20];
    int n,k,max_w;
    void Dfs(int start,int cout,int sum_w,int sum_v)
    {
        if(cout==k)
        {
            if(sum_v>max_v)
                max_v=sum_v;
            return;
        }
        for(int i=start;i<n;i++)
        {
            if(cout<k && sum_w+var[i+1].w<max_w)
                Dfs(start+1,cout+1,sum_w+var[i].w,sum_v+var[i].v);
        }
    }
    void main()
    {
        int c;
        cin>>c;
        for(int o=0;o<c;o++)
        {
            cin>>n>>k;
            for(int i=0;i<n;i++)
                cin>>var[i].v>>var[i].w;
            cin>>max_w;
            Dfs(0,0,0,0);
            cout<<max_v<<endl;
        }
    }
  • 相关阅读:
    java面试第八天
    java面试第七天
    java面试第六天
    java面试第五天
    java面试第四天
    SpringMVC导出Excel
    75. Autorelease机制及释放时机
    关于 SQLNET.AUTHENTICATION_SERVICES 验证方式的说明
    硬件十万个为什么——运放篇(五)PCB设计技巧
    eclipse到Android Studio的项目迁移
  • 原文地址:https://www.cnblogs.com/zhaoxinshanwei/p/3538419.html
Copyright © 2011-2022 走看看