zoukankan      html  css  js  c++  java
  • bzoj1751 [Usaco2005 qua]Lake Counting

    1751: [Usaco2005 qua]Lake Counting

    Time Limit: 5 Sec  Memory Limit: 64 MB
    Submit: 168  Solved: 130
    [Submit][Status]

    Description

    Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John's field, determine how many ponds he has.

    Input

    * Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

    Output

    * Line 1: The number of ponds in Farmer John's field.

    Sample Input


    10 12
    W........WW.
    .WWW.....WWW
    ....WW...WW.
    .........WW.
    .........W..
    ..W......W..
    .W.W.....WW.
    W.W.W.....W.
    .W.W......W.
    ..W.......W.

    Sample Output


    3

    OUTPUT DETAILS:

    There are three ponds: one in the upper left, one in the lower left,
    and one along the right side.


    省队集训上午的比赛又放弃治疗了……去刷刷水题来找回继续听课的勇气

    #include<cstdio>
    #include<iostream>
    using namespace std;
    const int mx[8]={1,1,1,0,0,-1,-1,-1};
    const int my[8]={1,0,-1,1,-1,1,0,-1};
    int n,m,ans;
    int map[110][110];
    void dfs(int x,int y)
    {
    	map[x][y]=0;
    	for (int k=0;k<8;k++)
    	  {
    		int nx=mx[k]+x;
    		int ny=my[k]+y;
    		if (map[nx][ny]) dfs(nx,ny);
    	  }
    }
    int main()
    {
    	scanf("%d%d",&n,&m);
    	for (int i=1;i<=n;i++)
    	  for (int j=1;j<=m;j++)
    	  {
    		char ch;
    		cin>>ch;
    		if (ch=='W')map[i][j]=1;
    	  }
    	for (int i=1;i<=n;i++)
    	  for (int j=1;j<=m;j++)
    	    if(map[i][j]){dfs(i,j);ans++;}
    	printf("%d",ans);
    }

    ——by zhber,转载请注明来源
  • 相关阅读:
    uni app 零基础小白到项目实战
    uni-app 事件以及事件绑定
    uni-app 事件以及事件绑定
    uni-app 组件
    uni-app 组件
    uni-app 网络请求
    uni-app 网络请求
    uni-app 图片上传实战
    uni-app 图片上传实战
    uni-app下拉刷新加载刷新数据
  • 原文地址:https://www.cnblogs.com/zhber/p/4036050.html
Copyright © 2011-2022 走看看