zoukankan      html  css  js  c++  java
  • 2014.6.14模拟赛【bzoj1646】[Usaco2007 Open]Catch That Cow 抓住那只牛

    Description

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

        农夫约翰被通知,他的一只奶牛逃逸了!所以他决定,马上幽发,尽快把那只奶牛抓回来.
        他们都站在数轴上.约翰在N(O≤N≤100000)处,奶牛在K(O≤K≤100000)处.约翰有
    两种办法移动,步行和瞬移:步行每秒种可以让约翰从z处走到x+l或x-l处;而瞬移则可让他在1秒内从x处消失,在2x处出现.然而那只逃逸的奶牛,悲剧地没有发现自己的处境多么糟糕,正站在那儿一动不动.
        那么,约翰需要多少时间抓住那只牛呢?

    Input

    * Line 1: Two space-separated integers: N and K

        仅有两个整数N和K.

     

    Output

    * Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

        最短的时间.

    Sample Input

    5 17
    Farmer John starts at point 5 and the fugitive cow is at point 17.

    Sample Output

    4

     

    OUTPUT DETAILS:

    The fastest way for Farmer John to reach the fugitive cow is to

    move along the following path: 5-10-9-18-17, which takes 4 minutes.

    好裸的bfs……n的规模才10w

    原来还想的是二进制dp,结果发现我在没事找事……

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    using namespace std;
    int n,m,head,tail=1;
    int dist[500001];
    int q[500001];
    inline bool mark(int x)
    {
    	return !(x<0||x>max(2*m+1,n+1));
    }
    int main()
    {
    	freopen("catchcow.in","r",stdin);
    	freopen("catchcow.out","w",stdout);
    	scanf("%d%d",&n,&m);
    	memset(dist,-1,sizeof(dist));
    	q[1]=n;dist[n]=0;
    	while (head<tail)
    	{
    		head++;
    		int now=q[head]-1;
    		if(mark(now)&&dist[now]==-1)
    		{
    			q[++tail]=now;
    			dist[now]=dist[q[head]]+1;
    		}
    		now=q[head]+1;
    		if(mark(now)&&dist[now]==-1)
    		{
    			q[++tail]=now;
    			dist[now]=dist[q[head]]+1;
    		}
    		now=q[head]*2;
    		if(mark(now)&&dist[now]==-1)
    		{
    			q[++tail]=now;
    			dist[now]=dist[q[head]]+1;
    		}
    		if(dist[m]!=-1) {printf("%d",dist[m]);return 0;}
    	}
    }
    

      

    ——by zhber,转载请注明来源
  • 相关阅读:
    django 2.2, celery 4.3,出现 kombu.exceptions.EncodeError: cannot serialize '_io.BufferedReader' object 的分析解决
    python 算法
    zabbix--api学习之路--get_hostgroup获取
    zabbix-api学习之路--auth获取
    短链(ShortURL)的Java实现
    几种I/O模型功能和性能对比
    JMeter压测Rest请求
    git如何设置账号密码
    TCP和UDP之间的区别和联系
    Java BigDecimal和double
  • 原文地址:https://www.cnblogs.com/zhber/p/4036087.html
Copyright © 2011-2022 走看看