zoukankan      html  css  js  c++  java
  • POJ 2488 A Knight's Journey

    A Knight's Journey
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 29226   Accepted: 10023

    Description

    Background 
    The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
    around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

     

    Problem 
    Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

    Input

    The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
    If no such path exist, you should output impossible on a single line.

    Sample Input

    3
    1 1
    2 3
    4 3

    Sample Output

    Scenario #1:
    A1
    
    Scenario #2:
    impossible
    
    Scenario #3:
    A1B3C1A2B4C2A3B1C3A4B2C4

    深索水题。,,。主要是方向被规定了。


    AC代码例如以下:

    #include<iostream>
    #include<cstring>
    using namespace std;
    
    struct H
    {
       int x;
       char y;
    }b[30],c[30];
    
    int dx[8]={-1,1,-2,2,-2,2,-1,1};
    int dy[8]={-2,-2,-1,-1,1,1,2,2};
    
    int a[30][30],vis[30][30];
    int n,m,bj;
    
    void dfs(int h,int z,int cur)
    {
        int i;
        if(cur==n*m)
        {
            if(bj==0)
            {
            for(i=0;i<cur;i++)
                cout<<b[i].y<<b[i].x;
                cout<<endl<<endl;
            bj=1;
            }
    
        }
        else
        {
            for(i=0;i<8;i++)
            {
                int xx,yy;
                xx=h+dx[i];
                yy=z+dy[i];
                if(!vis[xx][yy]&&xx>=1&&xx<=n&&yy>=1&&yy<=m)
                {
                    vis[xx][yy]=1;
                    b[cur].x=xx;b[cur].y=(char)(yy+'A'-1);
                    dfs(xx,yy,cur+1);
                    vis[xx][yy]=0;
                }
            }
    
        }
    }
    
    int main()
    {
        int t,cas=0;
        cin>>t;
        while(t--)
        {
            cas++;
            memset(a,0,sizeof a);
            memset(vis,0,sizeof vis);
            cin>>n>>m;
            bj=0;
            b[0].x=1;b[0].y=1+'A'-1;
            vis[1][1]=1;
            cout<<"Scenario #"<<cas<<":"<<endl;
            dfs(1,1,1);
            if(bj==0)
            {
                cout<<"impossible"<<endl<<endl;
            }
        }
        return 0;
    }
    




  • 相关阅读:
    计时器chronometer补充
    SpannableString富文本
    java数据结构整理(二)
    Java数据结构整理(一)
    graphical Layout调大一点
    eclipse快捷键
    弹出式菜单(下拉菜单)实现——PopupMenu
    二级横向菜单实现——ListView
    java求两个集合的差集
    Java中String的split()方法的一些需要注意的地方
  • 原文地址:https://www.cnblogs.com/zhchoutai/p/6722709.html
Copyright © 2011-2022 走看看