zoukankan      html  css  js  c++  java
  • uva558 Wormholes SPFA 求是否存在负环

    J - Wormholes
    Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

    Description

    Download as PDF

    In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

    • Wormholes are one-way only.

    • The time it takes to travel through a wormhole is negligible.

    • A wormhole has two end points, each situated in a star system.

    • A star system may have more than one wormhole end point within its boundaries.

    • For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).

    • Between any pair of star systems, there is at most one wormhole in either direction.

    • There are no wormholes with both end points in the same star system.

    All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may cause the person to end up 42 years in the past.


    A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This can be done using wormholes, of course.


    The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.

    Input 

    The input file starts with a line containing the number of cases c to be analysed. Each case starts with a line with two numbers n and m . These indicate the number of star systems ( $1 le n le 1000$) and the number of wormholes ( $0 le m le 2000$) . The star systems are numbered from 0 (our solar system) through n-1 . For each wormhole a line containing three integer numbers xy and t is given. These numbers indicate that this wormhole allows someone to travel from the star system numbered x to the star system numbered y, thereby ending up t ( $-1000 le t le 1000$) years in the future.

    Output 

    The output consists of c lines, one line for each case, containing the word possible if it is indeed possible to go back in time indefinitely, or not possible if this is not possible with the given set of star systems and wormholes.

    Sample Input 

    2
    3 3
    0 1 1000
    1 2 15
    2 1 -42
    4 4
    0 1 10
    1 2 20
    2 3 30
    3 0 -60
    

    Sample Output 

    possible
    not possible
    



    Miguel A. Revilla
    1998-03-10

    题意:问能否通过虫洞,回到过去,意思实际上就是求,最短路里面有不有负环。

    思路:SPFA 或者Bellman-ford 推断下有不有负环就能够了,对于SPFA,假设有负环,表明进栈次数大于等于n次。


    #include <iostream>
    #include <stdio.h>
    #include <string>
    #include <cstring>
    #include <algorithm>
    #include <cmath>
    #include <queue>
    #define INF 9999999
    using namespace std;
    
    int n,m;
    int num[2222];
    int dis[2222];
    int vis[2222];
    int f[2222];
    int u[2222],v[2222],w[2222],next[2222];
    
    int spfa()
    {
        queue<int>q;
        memset(vis,0,sizeof vis);
        memset(num,0,sizeof num);
    
        for(int i=0;i<=n;i++) dis[i]=INF;
        dis[0]=0;
        q.push(0);
        num[0]++;
    
        while(!q.empty())
        {
            int x=q.front(); q.pop();
            vis[x]=0;
            for(int i=f[x];i!=-1;i=next[i])
            if(dis[x]+w[i]<dis[v[i]])
            {
                dis[v[i]]=dis[x]+w[i];
                if(vis[v[i]]==0)
                {
                    vis[v[i]]=1;
                    q.push(v[i]);
                    num[v[i]]++;
                    if(num[v[i]]>=n)
                        return 1;
                }
            }
        }
    
        return 0;
    }
    
    int main()
    {
        int T;
        scanf("%d",&T);
    
        while(T--)
        {
            scanf("%d%d",&n,&m);
            memset(f,-1,sizeof f);
    
            for(int i=0;i<m;i++)
            {
                scanf("%d%d%d",&u[i],&v[i],&w[i]);
                next[i]=f[u[i]];f[u[i]]=i;
            }
    
            if(spfa()==0)
                puts("not possible");
            else
                puts("possible");
    
        }
        return 0;
    }
    
    /*
    5 4
    1 2 1
    1 3 2
    2 4 3
    2 5 2
    */
    





  • 相关阅读:
    [GEF]实现模板功能
    一篇WTP文章
    写代码的代码:JET
    投票选择eclipse.org的新界面
    在SWT里显示AWT对象
    Plugin.xml > Manifest.mf
    关于本体编程的实现
    一个用OWLS组装Web服务的例子
    感受Ruby on Rails
    通过OCP考试
  • 原文地址:https://www.cnblogs.com/zhchoutai/p/6865903.html
Copyright © 2011-2022 走看看