zoukankan      html  css  js  c++  java
  • PAT-A 1037. Magic Coupon

    1037. Magic Coupon

    The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

    For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

    Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed $2^{30}$.

    Output Specification:

    For each test case, simply print in a line the maximum amount of money you can get back.

    Sample Input:

    4
    1 2 4 -1
    4
    7 6 -2 -3
    

    Sample Output:

    43
    

    程序代码:

    #include<stdio.h>
    #define MAX 100000
    int coupons[MAX],value[MAX];
    int comp(void* a,void* b);
    int main()
    {
    	int m,n,i;
    	scanf("%d",&m);
    	for(i=0;i<m;i++)
    		scanf("%d",&coupons[i]);
    	scanf("%d",&n);
            for(i=0;i<n;i++)
                    scanf("%d",&value[i]);
    	qsort(coupons,m,sizeof(int),comp);
    	qsort(value,n,sizeof(int),comp);
    	int p=m-1,q=n-1;
    	long long sum = 0;
    	while(coupons[p]>0&&value[q]>0)
    	{
    		sum += coupons[p]*value[q];
    		p--;
    		q--;
    	}
    	p=0,q=0;
    	while(coupons[p]<0&&value[q]<0)
    	{
    		sum += coupons[p]*value[q];
    		p++;
    		q++;
    	}	
    	printf("%d",sum);
    	return 0;
    }
    int comp(void* a,void* b)
    {
    	int* m=(int*)a;
    	int* n=(int*)b;
    	return *m -*n;
    }
    
    
  • 相关阅读:
    vue 下载模板
    vue 使用XLSX 导入表格
    el-select 同时传递多个参数 id value.
    关于前端node 内存溢出
    js判断输入是否含有空格
    python中的内置函数总结
    Python的数据类型和常用方法大全
    简单认识python的数据类型和语法
    Part1.1 、RabbitMQ 操作使用
    Part1.2 、RabbitMQ -- Publish/Subscribe 【发布和订阅】
  • 原文地址:https://www.cnblogs.com/zhengkang/p/5734391.html
Copyright © 2011-2022 走看看