zoukankan      html  css  js  c++  java
  • PAT-A 1009. Product of Polynomials

    1009. Product of Polynomials

    This time, you are supposed to find A*B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

    Output Specification:

    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

    Sample Input

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    

    Sample Output

    3 3 3.6 2 6.0 1 1.6
    

    程序代码:

    #include<stdio.h>
    #include<math.h>
    #define EPSION 0.1
    double c[11]={0};
    int e[11]={0};
    double num[2001]={0};
    int main()
    {
    	int l1,l2;
    	scanf("%d",&l1);
    	int i;
    	double c_0;
    	int e_0;
    	for(i=0;i<l1;i++)
    	{
    		scanf("%d%lf",&e[i],&c[i]);
    	}
    	scanf("%d",&l2);
    	int j;
    	double cTmp=0;
    	int eTmp=0;
    	for(i=0;i<l2;i++)
    	{
    		scanf("%d%lf",&e_0,&c_0);
    		for(j=0;j<l1;j++)	
    		{
    			cTmp=c[j]*c_0;
    			eTmp=e[j]+e_0;
    			num[eTmp]+=cTmp;
    		}
    	}
    	int count = 0;
    	for(i=2000;i>=0;i--)
    	{
    		if(fabs(num[i])>=EPSION)
    			count++;
    	}
    	if(count == 0)
    	{
    		printf("0");
    		return 0;
    	}
    	printf("%d ",count);
    	for(i=2000;i>=0;i--)
    	{
    		if(fabs(num[i])>=EPSION)
    		{
    			printf("%d %.1f",i,num[i]);
    			count--;
    			if(count>0)
    				putchar(' ');
    		}
    	}	
    	return 0;
    }
    
  • 相关阅读:
    Mysql集群
    Redis集群
    Python3 实现数据读写分离设计
    PHP Session的优化使用
    防盗链与token运用
    PHP与REDIS
    优化设计提高sql类数据库的性能
    Nodejs密集型CPU解决方案
    可重入和线程安全
    信号处理函数编写规则
  • 原文地址:https://www.cnblogs.com/zhengkang/p/5768878.html
Copyright © 2011-2022 走看看