zoukankan      html  css  js  c++  java
  • Elevatorhdu-1008

    Elevator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 33731    Accepted Submission(s): 18412

    Problem Description

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

     

     

    Input

    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

     

     

    Output

    Print the total time on a single line for each test case.

     

     

    Sample Input

    1 2

    3 2 3 1

    0

     

     

    Sample Output

    17

    41

    #include<stdio.h>

    int main()

    {

        int n,i,j,k,a[120];

        while(scanf("%d",&n)&&(n!=0))

        {

          a[0]=0;

          for(i=1,k=0;i<=n;i++)

          {

            scanf("%d",&a[i]);

            if(a[i]>a[i-1])

            k=k+(a[i]-a[i-1])*6;

            else

            k=k+(a[i-1]-a[i])*4;

          }

          printf("%d ",k+n*5);

        }

        return 0;

    }

  • 相关阅读:
    打印水仙花数
    打印从1到k之间的所有素数
    Fibonacci数列小程序
    Fibonacci数
    水仙花数
    猴子吃桃问题
    5个数求最值—南阳acm
    三个数从小到大排序—南阳acm
    南阳acm奇偶数分离
    find the safest road--hdu1596
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3217382.html
Copyright © 2011-2022 走看看