zoukankan      html  css  js  c++  java
  • poj-1579Function Run Fun

    Function Run Fun

    Time Limit: 1000MS

     

    Memory Limit: 10000K

    Total Submissions: 14943

     

    Accepted: 7738

    Description

    We all love recursion! Don't we?

    Consider a three-parameter recursive function w(a, b, c):

    if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
    1

    if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
    w(20, 20, 20)

    if a < b and b < c, then w(a, b, c) returns:
    w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

    otherwise it returns:
    w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

    This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

    Input

    The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

    Output

    Print the value for w(a,b,c) for each triple.

    Sample Input

    1 1 1

    2 2 2

    10 4 6

    50 50 50

    -1 7 18

    -1 -1 -1

    Sample Output

    w(1, 1, 1) = 2

    w(2, 2, 2) = 4

    w(10, 4, 6) = 523

    w(50, 50, 50) = 1048576

    w(-1, 7, 18) = 1

    Source

    解题思路:

    1、  按照题目说的写出程序,但运算结果会超时,所以要用一个三维数组来保存。

    程序代码:

    #include<stdio.h>

    #include<string.h>

    int d[22][22][22];                              //用数组来保存之,这样就不会重复的调用函数了,可以节省很多时间

    int w(int a,int b,int c)

    {

        if(a<=0||b<=0||c<=0)                            //小于  0 则返回。

        return 1;

       

        else if(a>20||b>20||c>20)

        return d[20][20][20]=w(20,20,20);                   //  数组下标一定要是 20  不能是 abc 否则会溢出

        if(d[a][b][c])

        return d[a][b][c];                                   //  如果存在值,直接返回即可,不用再调用函数,可以节省时间

        else if(a<b&&b<c)

        return d[a][b][c]=w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);

        else

        return d[a][b][c]=w(a-1,b,c)+w(a-1,b-1,c)+w(a-1,b,c-1)-w(a-1,b-1,c-1);

    }

    int main()

    {

        int a,b,c;

        memset(d,0,sizeof(d));

        while(scanf("%d %d %d",&a,&b,&c)&&(a!=-1||b!=-1||c!=-1))

        {

            printf("w(%d, %d, %d) = %d ",a,b,c,w(a,b,c));

        }

        return 0;

    }

  • 相关阅读:
    HDU_5057_分块
    HYSBZ_2002_分块
    HDU_1166_树状数组
    HDU_5692_dfs序+线段树
    多重背包
    二进制中一的个数
    康托展开
    vector, map, queue,set常用总结
    错误票据
    高精度计算
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3254062.html
Copyright © 2011-2022 走看看