zoukankan      html  css  js  c++  java
  • POJ3009 Curling 2.0 解题报告

    Description

    On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

    Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


    Fig. 1: Example of board (S: start, G: goal)

    The movement of the stone obeys the following rules:

    • At the beginning, the stone stands still at the start square.
    • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
    • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
    • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
      • The stone hits a block (Fig. 2(b), (c)).
        • The stone stops at the square next to the block it hit.
        • The block disappears.
      • The stone gets out of the board.
        • The game ends in failure.
      • The stone reaches the goal square.
        • The stone stops there and the game ends in success.
    • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


    Fig. 2: Stone movements

    Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

    With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


    Fig. 3: The solution for Fig. D-1 and the final board configuration

    Input

    The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

    Each dataset is formatted as follows.

    the width(=w) and the height(=h) of the board 
    First row of the board
     
    ... 
    h-th row of the board

    The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

    Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

    0 vacant square
    1 block
    2 start position
    3 goal position

    The dataset for Fig. D-1 is as follows:

    6 6 
    1 0 0 2 1 0 
    1 1 0 0 0 0 
    0 0 0 0 0 3 
    0 0 0 0 0 0 
    1 0 0 0 0 1 
    0 1 1 1 1 1

    Output

    For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

    Sample Input

    2 1
    3 2
    6 6
    1 0 0 2 1 0
    1 1 0 0 0 0
    0 0 0 0 0 3
    0 0 0 0 0 0
    1 0 0 0 0 1
    0 1 1 1 1 1
    6 1
    1 1 2 1 1 3
    6 1
    1 0 2 1 1 3
    12 1
    2 0 1 1 1 1 1 1 1 1 1 3
    13 1
    2 0 1 1 1 1 1 1 1 1 1 1 3
    0 0

    Sample Output

    1
    4
    -1
    4
    10
    -1

           题目链接:http://poj.org/problem?id=3009

           解法类型:DFS

           解题思路:直接按照题目要求进行深度优先搜索即可。从起点开始,分别从一个方向搜索下去,如果搜索到目标,则返回1,如果出界或者移动次数大于十,就跳过此次搜索,搜索下一个方向,直到所有的都搜索一遍,最后的min就是最小值。

           算法实现:

    //STATUS:C++_AC_141MS_164K
    #include<stdio.h>
    const int MAXN=30;
    int DFS(int x,int y,int tot);
    char map[MAXN][MAXN];
    int x1,y1,x2,y2,w,h,min,
    dx[4]={-1,0,1,0},dy[4]={0,1,0,-1};
    int main()
    {
    //	freopen("in.txt","r",stdin);
    	int i,j;
    	while( scanf("%d%d",&w,&h) && w&&h )
    	{
    		min=0x7fffffff;
    
    		for(i=0;i<h;i++){
    			for(j=0;j<w;j++){
    				scanf("%d",&map[i][j]);
    				if(map[i][j]==2)x1=i,y1=j;
    				else if(map[i][j]==3)x2=i,y2=j;
    			}
    		}
    
    		DFS(x1,y1,0);
    
    		printf("%d\n",min<=10?min:-1);
    	}
    	return 0;
    }
    
    int DFS(int x,int y,int tot)
    {
    	int i,nx,ny;
    	for(i=0;i<4;i++){
    		nx=x+dx[i],ny=y+dy[i];
    		if(map[nx][ny]!=1 && nx>=0&&nx<h && ny>=0&&ny<w){  //判断方向
    			if(tot+1>10)continue; //搜索失败continue
    			do{                                                 //搜直线
    				if(map[nx][ny]==3){if(tot+1<min)min=tot+1;return 1;}  //search succeed
    				nx=nx+dx[i],ny=ny+dy[i];
    			}while(map[nx][ny]!=1 && nx>=0&&nx<h && ny>=0&&ny<w);
    		}
    		else continue;  //nx,ny方向为block
    		if(nx==h||nx<0 || ny==w||ny<0)continue; //出边界continue
    
    		map[nx][ny]=0;  //block变为vacant
    		DFS(nx-dx[i],ny-dy[i],tot+1);
    		map[nx][ny]=1;  //vacant变为block
    	}
    	return 0;  //搜索失败
    }

    
    
    
    
    
    
    
    
  • 相关阅读:
    scapy学习笔记(4)简单的sniffing 嗅探
    scapy学习笔记(3)发送包,SYN及TCP traceroute 扫描
    Linux查看CPU和内存使用情况
    MySQL关于根据日期查询数据的sql语句
    JSON 数据格式
    利用PyCharm进行Python远程调试
    pycharm远程调试配置
    Linux终端使用技巧
    每天一个linux命令(60):scp命令
    python-docx 使用教程
  • 原文地址:https://www.cnblogs.com/zhsl/p/2743633.html
Copyright © 2011-2022 走看看