zoukankan      html  css  js  c++  java
  • A1104. Sum of Number Segments

    Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

    Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

    Output Specification:

    For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

    Sample Input:

    4
    0.1 0.2 0.3 0.4 
    

    Sample Output:

    5.00
    
    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int main(){
        int N;
        double ans = 0, temp;
        scanf("%d", &N);
        for(int i = 1; i <= N; i++){
            scanf("%lf", &temp);
            ans += 1.0 * i * (N + 1 - i) * temp;
        }
        printf("%.2lf", ans);
        cin >> N;
        return 0;
    }

    总结:

    1、主要是找规律, 计算出每个数一共出现几次(与位置有关),然后做乘法再累加即可。第i个数(从1开始)出现的次数是:i * (n + 1 - i)。

    2、i * (N + 1 - i)有可能超过int的范围。 所以做类型转换时,1.0应该乘在式子的最前面。否则当int溢出后再做转换就无效了。

  • 相关阅读:
    设计模式
    C++下char/string跟int型转换比较
    function
    流程控制
    运算符
    type
    language
    phpbasic
    html标签集合
    课题六
  • 原文地址:https://www.cnblogs.com/zhuqiwei-blog/p/8515274.html
Copyright © 2011-2022 走看看