zoukankan      html  css  js  c++  java
  • A1140. Look-and-say Sequence

    Look-and-say sequence is a sequence of integers as the following:

    D, D1, D111, D113, D11231, D112213111, ...
    

    where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

    Input Specification:

    Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

    Output Specification:

    Print in a line the Nth number in a look-and-say sequence of D.

    Sample Input:

    1 8
    

    Sample Output:

    1123123111


    #include<iostream>
    #include<cstdio>
    #include<string>
    using namespace std;
    int hashTB[1000] = {0};
    int main(){
        string ss = "";
        int D, N;
        cin >> D >> N;
        ss = ss + (char)('0' + D);
        for(int i = 0; i < N - 1; i++){
            char pre = ss[0];
            int cnt = 1;
            string ss2 = "";
            for(int j = 1; j < ss.length(); j++){
                if(ss[j] == pre){
                    cnt++;
                }else{
                    ss2 += pre;
                    ss2 += (char)(cnt + '0');
                    pre = ss[j];
                    cnt = 1;
                }
            }
            ss2 += pre;
            ss2 += (char)(cnt + '0');
            ss = ss2;
        }
        cout << ss;
        cin >> N;
        return 0;
    }
    View Code

    总结:

    1、题意:题意不好理解时可以根据标题来猜意思。这题的意思让你看并且读出一个序列, 如一个序列是18882111,则可以读为1个1,3个8,1个2,3个1,再将其写成位在前个数描述在后的序列:11,83,21,13。再对这个新序列进行描述。

  • 相关阅读:
    xamp配置多域名站点
    POJ1611-The Suspects-ACM
    POJ2524-宗教问题-并查集-ACM
    POJ3274-牛的属性-HASH-ACM
    拓扑排序-DFS
    拓扑排序
    POJ1007-DNA Sorting-ACM
    POJ1258-Agri-Net-ACM
    wdcp-apache配置错误导致进程淤积进而内存吃紧
    wdcp-apache开启KeepAlive提高响应速度
  • 原文地址:https://www.cnblogs.com/zhuqiwei-blog/p/9566605.html
Copyright © 2011-2022 走看看