zoukankan      html  css  js  c++  java
  • A1146. Topological Order

    This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

    gre.jpg

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

    Output Specification:

    Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

    Sample Input:

    6 8
    1 2
    1 3
    5 2
    5 4
    2 3
    2 6
    3 4
    6 4
    5
    1 5 2 3 6 4
    5 1 2 6 3 4
    5 1 2 3 6 4
    5 2 1 6 3 4
    1 2 3 4 5 6
    

    Sample Output:

    3 4

    #include<iostream>
    #include<cstdio>
    using namespace std;
    int G[1001][1001] = {0}, dele[1001] = {0};
    int N, M, K;
    int main(){
        scanf("%d%d", &N, &M);
        for(int i = 0; i < M; i++){
            int v1, v2;
            scanf("%d%d", &v1, &v2);
            G[v1][v2] = 1;
        }
        scanf("%d", &K);
        int ans[10000], pt = 0;
        for(int i = 0; i < K; i++){
            fill(dele, dele + 1001, 0);
            int isTopl = 1;
            for(int j = 1; j <= N; j++){
                int v;
                int tag = 1;
                scanf("%d", &v);
                for(int k = 1; k <= N; k++){
                    if(dele[k] == 0 && G[k][v] != 0){
                        tag = 0;
                        break;
                    }
                }
                if(tag == 0){
                    isTopl = 0;
                }else{
                    dele[v] = 1;
                }
            }
            if(isTopl == 0){
                ans[pt++] = i;
            }
        }
        for(int i = 0; i < pt; i++){
            if(i == pt - 1)
                printf("%d", ans[i]);
            else printf("%d ", ans[i]);
        }
        cin >> N;
    }
    View Code

    总结:

    1、题意:给出一个有向图,检验给出的序列是否是拓扑排序。

    2、拓扑排序要求每次删除一个入度为0的节点。

  • 相关阅读:
    如何使用Jquery 引入css文件
    html如何绘制带尖角(三角)的矩形
    让HTML标签、DIV、SPAN拥有focus事件和blur事件,聚焦和失焦
    html如何引用另一个html的内容
    HTML中块级元素与内联元素有什么区别 ?
    一个js文件如何加载另外一个js文件
    在线工具-程序员的工具箱-在线Cron表达式生成器
    oracle fm格式化
    html如何让label在div中的垂直方向居中显示?
    服务发现框架选型: Consul、Zookeeper还是etcd ?
  • 原文地址:https://www.cnblogs.com/zhuqiwei-blog/p/9569768.html
Copyright © 2011-2022 走看看