zoukankan      html  css  js  c++  java
  • hdoj 1305字典树水题之二

    Immediate Decodability

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1197    Accepted Submission(s): 624


    Problem Description
    An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

    Examples: Assume an alphabet that has symbols {A, B, C, D}

    The following code is immediately decodable:
    A:01 B:10 C:0010 D:0000

    but this one is not:
    A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
     
    Input
    Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
     
    Output
    For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
     
    Sample Input
    01
    10
    0010
    0000
    9
    01
    10
    010
    0000
    9
    Sample Output
    Set 1 is immediately decodable Set
    2 is not immediately decodable
    题目大意:判定给出的一组数,是否有前缀相同的。以9为组之间的分割符
    代码:
    View Code
    #include<stdio.h>
    #include<malloc.h>
    #include<string.h>
    struct node
    {
        struct node *next[3];
    };
    
    int insert(char *str,node *T)
    {
        node *p,*q;
        int len,i,id,flag=0,j;
        p=T;
        len=strlen(str);
        for(i=0;i<len;++i)
        {
            id=str[i]-'0';
            if(p->next[id]==NULL)
            {
                q=(node*)malloc(sizeof(node));
                for(j=0;j<3;++j)
                    q->next[j]=NULL;
                p->next[id]=q;
            }
            else if(i==len-1&&p->next[id]!=NULL)
                flag=1;
            p=p->next[id];
        }
        return flag;
    }
    
    
    int main()
    {
        node *T;
        char str[11];
        int flag,i,n=0;
        T=(node*)malloc(sizeof(node));
        for(i=0;i<3;++i)
            T->next[i]=NULL;
        while(scanf("%s",str)!=EOF)
        {
            flag=0;
            while(strcmp(str,"9")!=0)
            {
                if(insert(str,T))
                    flag=1;
                scanf("%s",str);
            }
            n++;
            if(!flag)
                printf("Set %d is immediately decodable\n",n);
            else
                printf("Set %d is not immediately decodable\n",n);
        }
    
        return 0;
    }
  • 相关阅读:
    项目发展规划 题解
    善意的投票&小M的作物 题解
    方格取数加强版 题解
    BZOJ1001 狼抓兔子 题解
    a
    一个搬运
    代码“小白”的温故而知新(一)-----OA管理系统
    工作流-----WorkFlow
    温习SQL语句
    浅谈MVC基础
  • 原文地址:https://www.cnblogs.com/zibuyu/p/3020334.html
Copyright © 2011-2022 走看看