题目链接:https://vjudge.net/problem/UVA-10976
It is easy to see that for every fraction in the form 1k(k > 0), we can always find two positive integers x and y, x ≥ y, such that:
1/k=1/x+1/y
Now our question is: can you write a program that counts how many such pairs of x and y there are for any given k?
Input
Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).
Output
For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of x and y, as shown in the sample output.
Sample Input
2
12
Sample Output
2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24
题意概述:输入正整数k,找到所有的正整数x≥y,使得1/k=1/x+1/y;
解题思路:既然要求找出所有的x、y,枚举对象自然就是x、y了。可问题在于,枚举的范围如何? 从1/12=1/156+1/13可以看出,x可以比y大很多。难道要无休止地枚举下去?当然不是。因为1/k=1/x+1/y,所以1/k>1/y,所以y>k;又因为x>=y,所以1/x≤1/y,且1/k=1/x+1/y,所以1/k-1/y≤1/y,得y≤2k;这样,只需要在k+1到2k范围之内枚举y,然后根据y尝试 计算出x即可,因为1/k=1/x+1/y,得x=ky/(y-k)。暴力枚举也需要进行数学推倒可以大大缩小枚举的范围。
代码如下:
#include<iostream>
using namespace std;
const int maxn=1000;
int ansx[maxn],ansy[maxn];
int main()
{
int k;
int cnt;
while(cin>>k)
{
cnt=0;
for(int j=k+1;j<=2*k;j++)
{
if((k*j)%(j-k)==0&&k*j/(j-k)>=j)
{
ansx[cnt]=k*j/(j-k);
ansy[cnt]=j;
cnt++;
}
}
cout<<cnt<<endl;
for(int i=0;i<cnt;i++)
{
cout<<"1/"<<k<<"=1/"<<ansx[i]<<"+1/"<<ansy[i]<<endl;
}
}
return 0;
}