zoukankan      html  css  js  c++  java
  • PAT 甲级 1105 Spiral Matrix

    https://pintia.cn/problem-sets/994805342720868352/problems/994805363117768704

    This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; mn; and mn is the minimum of all the possible values.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104​​. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:

    12
    37 76 20 98 76 42 53 95 60 81 58 93
    

    Sample Output:

    98 95 93
    42 37 81
    53 20 76
    58 60 76
    
     

    代码:

    #include <bits/stdc++.h>
    using namespace std;
    
    const int maxn = 1e5 + 10;
    int N;
    int num[maxn];
    int ans[1010][1010];
    
    int main() {
        scanf("%d", &N);
        for(int i = 0; i < N; i ++)
            scanf("%d", &num[i]);
        sort(num, num + N);
        for(int i = 0; i < N / 2; i ++)
            swap(num[i], num[N - i - 1]);
    
        int line, row;
        for(row = sqrt((double)N); row >= 1; row --) {
            if(N % row == 0) {
                line = N / row;
                break;
            }
        }
    
        int up = 0, down = line - 1, left = 0, right = row - 1, cnt = 0;
        while(true) {
            for(int j = left; j <= right; j ++) ans[up][j] = num[cnt ++];
            if(++ up > down) break;
            for(int i = up; i <= down; i ++) ans[i][right] = num[cnt ++];
            if(-- right < left) break;
            for(int j = right; j >= left; j --) ans[down][j] = num[cnt ++];
            if(-- down < up) break;
            for(int i = down; i >= up; i --) ans[i][left] = num[cnt ++];
            if(++ left > right) break;
        }
    
        for(int i = 0; i < line; i ++) {
            for(int j = 0; j < row; j ++) {
                printf("%d", ans[i][j]);
                printf("%s", j != row - 1 ? " " : "
    ");
            }
        }
        return 0;
    }
    

      中午好!

  • 相关阅读:
    oracle--角色权限
    oracle--权限的传递
    oracle--少见操作、如何调整dos窗口大小、字符集设置
    oracle--对象权限
    oracle-系统权限管理
    IOS-swift5.1快速入门之旅
    oracle--用户区别sys和system
    JSP基础--EL表达式
    JSP基础--javaBean
    hdu_A Walk Through the Forest ——迪杰特斯拉+dfs
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/10355978.html
Copyright © 2011-2022 走看看