zoukankan      html  css  js  c++  java
  • HDU 1089 到1096 a+b的输入输出练习

    http://acm.hdu.edu.cn/showproblem.php?pid=1089

    Problem Description
    Your task is to Calculate a + b.
    Too easy?! Of course! I specially designed the problem for acm beginners. 
    You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim. 
     
    Input
    The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line. 
     
    Output
    For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
     
    Sample Input
    1 5 10 20
     
    Sample Output
    6 30
     
    代码:
    #include <iostream>
    
    using namespace std;
    
    int main()
    {
        int a,b;
        int sum=0;
        while(cin>>a>>b)
        {
            sum=a+b;
         cout<<sum<<endl;
        }
        return 0;
    }
    

      

    http://acm.hdu.edu.cn/showproblem.php?pid=1090

    Problem Description
    Your task is to Calculate a + b.
     
    Input
    Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line. 
     
    Output
    For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
     
    Sample Input
    2 1 5 10 20
     
    Sample Output
    6 30
     
    代码:
    #include <iostream>
    
    using namespace std;
    
    int main()
    {
        int T;
        cin >> T;
        int sum=0;
        for(int i = 1;i <= T;i ++)
        {
            int a,b;
            cin>>a>>b;
            sum=a+b;
            cout<<sum<<endl;
        }
        return 0;
    }
    

      

    http://acm.hdu.edu.cn/showproblem.php?pid=1091

    Problem Description
    Your task is to Calculate a + b.
     
    Input
    Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
     
    Output
    For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
     
    Sample Input
    1 5 10 20 0 0
     
    Sample Output
    6 30
     
    代码:
    #include <iostream>
    
    using namespace std;
    
    int main()
    {
        int a,b;
        int sum = 0;
        while(cin >> a >> b)
        {
            if(a == 0 && b == 0)
                break;
            else
                sum = a + b;
            cout << sum << endl;
        }
        return 0;
    }
    

      

    http://acm.hdu.edu.cn/showproblem.php?pid=1092

    Problem Description
    Your task is to Calculate the sum of some integers.
     
    Input
    Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
     
    Output
    For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
     
    Sample Input
    4 1 2 3 4 5 1 2 3 4 5 0
     
    Sample Output
    10 15
     
    代码:
    #include <iostream>
    
    using namespace std;
    
    int main()
    {
        int n;
        while(cin>>n)
        {
            if(n==0)
                break;
            int sum=0;
            for(int i=1; i<=n; i++)
            {
                int x;
                cin>>x;
                sum+=x;
            }
            cout<<sum<<endl;
        }
        return 0;
    }
    

      

    http://acm.hdu.edu.cn/showproblem.php?pid=1093

    Problem Description
    Your task is to calculate the sum of some integers.
     
    Input
    Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
     
    Output
    For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
     
    Sample Input
    2 4 1 2 3 4 5 1 2 3 4 5
     
    Sample Output
    10 15
     
    代码:
    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
        int N,M;
        cin >> N;
    
        for(int i=1;i<=N;i++)
        {
             int sum=0;
            cin>>M;
            for(int j=1;j<=M;j++)
            {
                int x;
                cin>>x;
                sum+=x;
            }
            cout<<sum<<endl;
        }
        return 0;
    }
    

      

    http://acm.hdu.edu.cn/showproblem.php?pid=1094

    Problem Description
    Your task is to calculate the sum of some integers.
     
    Input
    Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line. 
     
    Output
    For each test case you should output the sum of N integers in one line, and with one line of output for each line in input. 
     
    Sample Input
    4 1 2 3 4 5 1 2 3 4 5
     
    Sample Output
    10 15
     
    代码:
    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
        int N;
        while(scanf("%d",&N)!=EOF)
        {
            int sum=0;
            for(int i=1;i<=N;i++)
            {
                int x;
                cin>>x;
                sum+=x;
            }
            cout<<sum<<endl;
        }
        return 0;
    }
    

      

    http://acm.hdu.edu.cn/showproblem.php?pid=1095

    Problem Description
    Your task is to Calculate a + b.
     
    Input
    The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line. 
     
    Output
    For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line. 
     
    Sample Input
    1 5 10 20
     
    Sample Output
    6 30
     
    代码:
    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
        int a,b;
        int sum=0;
        while(cin>>a>>b)
        {
            sum=a+b;
            cout<<sum<<endl<<endl;
        }
        return 0;
    }
    

    http://acm.hdu.edu.cn/showproblem.php?pid=1096

    Problem Description
    Your task is to calculate the sum of some integers.
     
    Input
    Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
     
    Output
    For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
     
    Sample Input
    3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
     
    Sample Output
    10 15 6
     
    代码:
    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
        int N,M;
        cin>>N;
        for(int i=1;i<=N;i++)
        {
            int sum=0;
            cin>>M;
            for(int j=1;j<=M;j++)
            {
                int x;
                cin>>x;
                sum+=x;
            }
            if(N!=i)
                cout<<sum<<endl<<endl;
            else
                cout<<sum<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    NFC技术:让Android自动打开网页
    NFC技术:让Android自动运行程序
    NFC技术:概述
    路由器端口映射实现外网访问本地服务器
    Java之MySql数据库链接
    最短路径之Dijkstra算法及实例分析
    各种排序算法的时间性能比较
    C#实现基于ffmpeg加虹软的人脸识别
    虹软SDK在nodejs中的集成
    Android 虹软2.0人脸识别,注册失败问题 分析synchronized的作用
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/9196984.html
Copyright © 2011-2022 走看看