zoukankan      html  css  js  c++  java
  • POJ 1797 Heavy Transportation

    http://poj.org/problem?id=1797

    Description

    Background 
    Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
    Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

    Problem 
    You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

    Input

    The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

    Sample Input

    1
    3 3
    1 2 3
    1 3 4
    2 3 5
    

    Sample Output

    Scenario #1:
    4

    代码:

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    
    #define inf 0x3f3f3f3f
    int T, N, M;
    int vis[1010], dis[1010];
    int mp[1010][1010];
    
    int dijkstra(int st) {
        memset(vis, 0, sizeof(vis));
        memset(dis, -inf, sizeof(dis));
    
        int temp;
        dis[st] = 0;
        for(int i = 2; i <= N; i ++)
            dis[i] = mp[st][i];
    
        for(int i = 1; i <= N; i ++) {
            int minn = -1;
            for(int j = 1; j <= N; j ++) {
                if(vis[j] == 0 && dis[j] > minn) {
                    temp = j;
                    minn = dis[j];
                }
            }
            vis[temp] = 1;
            for(int k = 1; k <= N; k ++)
                if(!vis[k] && dis[k] < min(dis[temp], mp[temp][k]))
                dis[k] = min(dis[temp], mp[temp][k]);
        }
        return dis[N];
    }
    
    int main() {
        scanf("%d", &T);
        int cnt = 0;
        while(T --) {
            scanf("%d%d", &N, &M);
            memset(mp, 0, sizeof(mp));
            for(int i = 1; i <= M; i ++) {
                int s, t, cost;
                scanf("%d%d%d", &s, &t, &cost);
                    mp[t][s] = mp[s][t] = cost;
            }
    
            cnt ++;
            int ans = dijkstra(1);
            printf("Scenario #%d:
    %d
    
    ", cnt, ans);
        }
        return 0;
    }
    

      

  • 相关阅读:
    shell脚本中执行python脚本并接收其返回值的例子
    linux查找所有文件中某个字符串
    Shell脚本中单引号(‘)和双引号(“)的使用区别
    第一个shell脚本
    shell 比较符号
    source ~/.bash_profile是什么意思
    bash shell:获取当前脚本的绝对路径(pwd/readlink)
    poj 3307 Smart Sister 打表解因子生成数问题
    Python将JSON格式数据转换为SQL语句以便导入MySQL数据库
    UISegmentedControl的具体使用
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/9739647.html
Copyright © 2011-2022 走看看