zoukankan      html  css  js  c++  java
  • PAT 甲级 1024 Palindromic Number

    https://pintia.cn/problem-sets/994805342720868352/problems/994805476473028608

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:

    67 3
    

    Sample Output 1:

    484
    2
    

    Sample Input 2:

    69 3
    

    Sample Output 2:

    1353
    3

    代码:

    #include <bits/stdc++.h>
    using namespace std;
    
    bool pal(char a[]) {
        int len = strlen(a);
        for (int i = 0; i < len; i ++)
            if (a[i] != a[len - 1 - i])
                return false;
        return true;
    }
    
    void add(char a[]) {
        char tmp[1000];
        int k = 0;
        int len = strlen(a);
        for (int i = 0; i < len; i ++) {
            tmp[i] = a[i] - '0' + a[len - 1 - i] - '0' + k;
            k = tmp[i] / 10;
            tmp[i] = tmp[i] % 10 + '0';
        }
        for (int i = 0; i < len; i++)
            a[i] = tmp[i];
        if (k)
            a[len ++] = '1';
        a[len] = '';
    }
    
    int main() {
        char a[1000];
        int k;
        scanf("%s%d", a, &k);
        int cnt = 0;
        while(cnt < k && !pal(a)) {
            add(a);
            cnt ++;
        }
        
        int len = strlen(a);
        for (int i = len - 1; i >= 0; i --)
            printf("%c", a[i]);
        printf("
    %d
    ", cnt);
    }
    

      

  • 相关阅读:
    Oracle 查看表空间的大小及使用情况sql语句
    Oracle审计--AUD$占用空间较大处理方案
    system表空间爆满解决方法
    Oracle查询库中记录数大于2千万的所有表
    oracle 百万行数据优化查询
    React (Native) Rendering Lifecycle
    React于React native的渲染机制
    Virtual DOM的渲染机制--猜测
    react的优点:兼容了dsl语法与UI的组件化管理
    What is Babel?---JSX and React
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/9841844.html
Copyright © 2011-2022 走看看