zoukankan      html  css  js  c++  java
  • hud4160 Dolls

    Problem Description
    Do you remember the box of Matryoshka dolls last week? Adam just got another box of dolls from Matryona. This time, the dolls have different shapes and sizes: some are skinny, some are fat, and some look as though they were attened. Specifically, doll i can be represented by three numbers wi, li, and hi, denoting its width, length, and height. Doll i can fit inside another doll j if and only if wi < wj , li < lj , and hi < hj . That is, the dolls cannot be rotated when fitting one inside another. Of course, each doll may contain at most one doll right inside it. Your goal is to fit dolls inside each other so that you minimize the number of outermost dolls.
     
    Input
    The input consists of multiple test cases. Each test case begins with a line with a single integer N, 1 ≤ N ≤ 500, denoting the number of Matryoshka dolls. Then follow N lines, each with three space-separated integers wi, li, and hi (1 ≤ wi; li; hi ≤ 10,000) denoting the size of the ith doll. Input is followed by a single line with N = 0, which should not be processed.
     
    Output
    For each test case, print out a single line with an integer denoting the minimum number of outermost dolls that can be obtained by optimally nesting the given dolls.
     
    Sample Input
    3
    5 4 8
    27 10 10
    100 32 523
    3
    1 2 1
    2 1 1
    1 1 2
    4
    1 1 1
    2 3 2
    3 2 2
    4 4 4
    0
     
    Sample Output
    1
    3
    2
    二分图匹配
    View Code
    #include<stdio.h>
    #include<string.h>
    bool map[550][550],f[550];
    int t,g[550];
    struct node{
        int x,y,z;
    }b[550];
    bool fun(int a)
    {
        int i;
        for(i=1;i<=t;i++)
            if(map[a][i]&&!f[i])
            {
                f[i]=1;
                if(!g[i]||fun(g[i]))
                {
                    g[i]=a;
                    return 1;
                }
            }
            return 0;
    }
    int main()
    {
        int i,j,num;
        while(scanf("%d",&t),t)
        {
            num=0;
            for(i=1;i<=t;i++)
                scanf("%d%d%d",&b[i].x,&b[i].y,&b[i].z);
            memset(map,0,sizeof(map));
            memset(g,0,sizeof(g));
            for(i=1;i<=t;i++)
                for(j=1;j<=t;j++)
                    if(b[i].x>b[j].x&&b[i].y>b[j].y&&b[i].z>b[j].z)
                        map[i][j]=1;
                    for(i=1;i<=t;i++)
                    {
                        memset(f,0,sizeof(f));
                        num+=fun(i);
                    }
                    printf("%d\n",t-num);
        }
        return 0;
    }
  • 相关阅读:
    django--orm操作
    路由
    django ----视图和路由
    DJango 前三天小结
    JQuery----操作01
    前端---JQuery初识
    前端----jsDOM
    前端---js02
    前端-----js
    面向对象
  • 原文地址:https://www.cnblogs.com/zlyblog/p/3033001.html
Copyright © 2011-2022 走看看