zoukankan      html  css  js  c++  java
  • poj-1164 The Castle

         1   2   3   4   5   6   7  
    
    #############################
    1 # | # | # | | #
    #####---#####---#---#####---#
    2 # # | # # # # #
    #---#####---#####---#####---#
    3 # | | # # # # #
    #---#########---#####---#---#
    4 # # | | | | # #
    #############################
    (Figure 1)

    # = Wall
    | = No wall
    - = No wall

    Figure 1 shows the map of a castle.Write a program that calculates 
    1. how many rooms the castle has 
    2. how big the largest room is 
    The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls. 

    Input

    Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

    Output

    Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

    Sample Input

    4
    7
    11 6 11 6 3 10 6
    7 9 6 13 5 15 5
    1 10 12 7 13 7 5
    13 11 10 8 10 12 13

    Sample Output

    5
    9

    这题的题面很长,大致意思是每个坐标有东南西北四个方位,每个方位都可能有墙。1,2,4,8分别是西,北,东,南
    四个方位有墙,输入的每位数字是墙的标号之和,比如11是1+2+8,就是西,北,南有墙,要求算的是有多少个连通块
    和最大连通块连了几个坐标。
    这四个数字很特殊,没错,就是用二进制的位运算判断。
    附代码:
    #include <cstdio>
    #include <cstring>
    #include <iostream>
    using namespace std;
    const int M = 55;
    int map[M][M];
    int vis[M][M];
    int n,m,maxx=0,cnt=0,res=0;
    void dfs(int x,int y){
        
        if((y-1)>=1&&!(map[x][y]&1)&&!vis[x][y-1]){
         //   cout<<1<<endl;
            vis[x][y-1]=1;
            cnt++;
            dfs(x,y-1);
        }
        if((x-1)>=1&&!(map[x][y]&2)&&!vis[x-1][y]){
         //   cout<<2<<endl;
            vis[x-1][y]=1;
            cnt++;
            dfs(x-1,y);
        }
        if((y+1)<=m&&!(map[x][y]&4)&&!vis[x][y+1]){
         //   cout<<3<<endl;
            vis[x][y+1]=1;
            cnt++;
            dfs(x,y+1);
        }
        if((x+1)<=n&&!(map[x][y]&8)&&!vis[x+1][y]){
         //   cout<<4<<endl;
            vis[x+1][y]=1;
            cnt++;
            dfs(x+1,y);
        }
    }
    int main(){
        while(cin>>n>>m){
            memset(vis,0,sizeof(vis));
            for(int i=1;i<=n;i++){
                for(int j=1;j<=m;j++){
                    cin>>map[i][j];
                }
            }
            maxx=0;res=0;cnt=1;
            for(int i=1;i<=n;i++){
                for(int j=1;j<=m;j++){
                    if(!vis[i][j]){
                        if(map[i][j]!=15)
                        {
                //        cout<<i<<" "<<j<<endl;
                        vis[i][j]=1;
                        dfs(i,j);
                        
                        maxx=max(cnt,maxx);
                      //  cout<<cnt<<" maxx"<<endl;
                        cnt=1;
                        }
                        res++;
                    }
                }
            }
            cout<<res<<endl<<maxx<<endl;
        }
        return 0;
    }
    

      




  • 相关阅读:
    java正则表达式
    SpringAOP03 项目脚手架、自定义注解、织入切面、引介增强
    SpringAOP02 自定义注解
    servlet01 项目demo、servlet生命周期
    SpringBoot15 sell02 订单模块
    SpringBoot15 sell01 项目创建、MySQL数据库连接、日志配置、开发热部署、商品信息模块
    datatables01 安装、数据源、选中行事件、新增一行数据、删除一行数据
    Navicat 连接阿里云的 MySQL
    linux内核中ip,tcp等头的定义(转)
    TCPflow:在Linux中分析和调试网络流量的利器(转)
  • 原文地址:https://www.cnblogs.com/zmin/p/7340151.html
Copyright © 2011-2022 走看看