zoukankan      html  css  js  c++  java
  • A-B Game 水题+longlong

    题目来源:http://acm.fzu.edu.cn/contest/problem.php?cid=134&sortid=8

    Problem H A-B Game

    Accept: 103    Submit: 237
    Time Limit: 1000 mSec    Memory Limit : 32768 KB

     Problem Description

    Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

     Input

    The first line of the date is an integer T, which is the number of the text cases.

    Then T cases follow, each case contains two integers A and B described above.

    1 <= T <=100, 2 <= B < A < 100861008610086

     Output

    For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

     Sample Input

    2
    5 3
    10086 110

     Sample Output

    Case 1: 1
    Case 2: 7

    题意: a= A - (A %x)  ,我们知道 a 是递减函数, 直到=<b 。因此我们需要 求 a的最小值 , 即求 (A%x)的最大值, 经过测试,发现 (A%x) 的最大值 是 (A-1)/2。

    代码如下:

    #include<iostream>
    #include<stdlib.h>
    #include<stdio.h>
    #include<math.h>
    #include<string.h>
    #include<string>
    #include<queue>
    #include<algorithm>
    #include<map>
    
    using namespace std;
    typedef long long LL;
    
    int solve(LL a, LL b)
    {
        int num=0;
        while(a>b)
        {
            num++;
            a=a-(a-1)/2;
        }
        return num;
    }
    int main()
    {
        LL m,n;
        int t,k=1;
        cin>>t;
        while(t--)
        {
            cin>>m>>n;
            printf("Case %d: ",k++);
            cout<<solve(m,n)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    使用 Selenium
    Senium 简介
    第8章 动态渲染页面爬取
    Ajax 结果提取
    Ajax 分析方法
    WINDOW 2008多人访问设置
    Windows 2012设置允许单个用户连接多个会话的方法
    Windows Server 2012开启多人远程
    BOM 表
    修复材料工单分配材料订单重复占料问题的开发
  • 原文地址:https://www.cnblogs.com/zn505119020/p/3601042.html
Copyright © 2011-2022 走看看