zoukankan      html  css  js  c++  java
  • 最大公约数和最小公倍数

    Sixth Grade Math

    Time Limit:   1000MS       Memory Limit:   65535KB
    Submissions:   162       Accepted:   120
    Description

    In sixth grade, students are presented with different ways to calculate the Least Common Multiple (LCM) and the Greatest Common Factor (GCF) of two integers.   The LCM of two integers a and b is the smallest positive integer that is a multiple of both a and b.  The GCF of two non-zero integers a and b is the largest positive integer that divides both a and b without remainder. 

    For this problem you will write a program that determines both the LCM and GCF for positive integers.

    Input

    The first line of input contains a single integer N, (1 < = N < = 1000) which is the number of data sets that follow.  Each data set consists of a single line of input containing two positive integers, a and b,  (1< = a,b  < = 1000) separated by a space.

    Output

    For each data set, you should generate one line of output with the following values:  The data set number as a decimal integer (start counting at one), a space, the LCM, a space, and the GCF.

    Sample Input

    3 
    5 10 
    7 23 
    42 56 

    Sample Output

    1 10 5 
    2 161 1 
    3 168 14 




    #include<stdio.h>
    int main()
    {
    int n,i;
    int a[1000],b[1000];
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
    scanf("%d%d",&a[i],&b[i]);
    }
    for(i=1;i<=n;i++)
    {
    int da,xiao,yu;
    if(a<b)
    {
    int t=a[i];
    a[i]=b[i];
    b[i]=t;
    }
    da=a[i];
    xiao=b[i];
    while(b[i])
    {
    yu=a[i]%b[i];
    a[i]=b[i];
    b[i]=yu;
    }
    printf("%d %d %d ",i,da*xiao/a[i],a[i]);
    }
    return 0;
    }



  • 相关阅读:
    Battle ships(二分图,建图,好题)
    棋盘游戏(二分图,删边)
    Girls' research(manacher)
    jenkins配置发送测试结果邮件
    Win10电脑如何更改开机启动项
    Ubuntu 18.04 固定pycharm图标固定到启动栏
    ubuntu下Fiddler抓包
    一个数据去重sql
    JENKINS针对不同项目组对用户进行权限分配
    jenkins添加用户
  • 原文地址:https://www.cnblogs.com/zou20134585/p/gongyuegongbeishu.html
Copyright © 2011-2022 走看看