zoukankan      html  css  js  c++  java
  • POJ 1365 Prime Land

                      Prime Land

    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 2122   Accepted: 979

    Description

    Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0,1,2,... denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers ekx, ekx-1, ..., e1, e0, (ekx > 0), that  The sequence 

    (ekx, ekx-1, ... ,e1, e0



    is considered to be the representation of x in prime base number system. 

    It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple. 

    Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''. 

    Help people in the Prime Land and write a corresponding program. 

    For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi. 

    Input

    The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number 0.

    Output

    The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There is no line in the output corresponding to the last ``null'' line of the input.

    Sample Input

    17 1
    5 1 2 1
    509 1 59 1
    0

    Sample Output

    2 4
    3 2
    13 1 11 1 7 1 5 1 3 1 2 1

    题意:sum=(x1^n1)*(x2^n2)......(xn^nn) 求sum-1的因式分解

        通过这道题学会了sscanf将字符窜转换成数字

      sscanf(str,"%d",&t);//str是字符窜,t要赋予地址
    还有个strtok,这个函数不错以后可以用的着
    http://www.cppblog.com/masiyou/archive/2009/10/07/98038.html
    #include <string.h>
    #include <stdio.h>
    
    int main(void)
    {
       char input[16] = "abc,dhh,eee";
       char *p;
    
       /* strtok places a NULL terminator
       in front of the token, if found */
       p = strtok(input, ",");
       if (p)   printf("%s\n", p);
    
       /* A second call to strtok using a NULL
       as the first parameter returns a pointer
       to the character following the token  */
       p = strtok(NULL, ",");
       if (p)   printf("%s\n", p);
    
       p = strtok(NULL, ",");
       if (p)   printf("%s\n", p);
       return 0;
    }
    #include <stdio.h>
    #include<stdlib.h>
    #include<string.h>
    #include<math.h>
    #include<algorithm>
    using namespace std;
    const int MAXN=40000;
    struct Node
    {
        int a,b;
    }rem[1000];
    
    char ss[1000];
    int prime[MAXN],num[1000],vis[MAXN];
    char str[1000];
    int cnt,tes;
    
    void init()
    {
        int i,j;
        tes=0;
        memset(vis,0,sizeof(vis));
        for(i=2; i<MAXN; i++)
        {
            if(vis[i]==0)
            {
                for(j=i+i; j<MAXN; j+=i)
                {
                    vis[j]=1;
                }
            }
        }
        tes=0;
        for(i=2; i<MAXN; i++)
        {
            if(vis[i]==0)   prime[tes++]=i;
        }
    }
    
    void get_num()
    {
        int tot,i;
        cnt=tot=0;
        int t;
        for(i=0; ss[i]; i++)
        {
            if(ss[i]==' ')
            {
                str[tot]='\0';
                sscanf(str,"%d",&t);
                num[cnt++]=t;
                tot=0;
            }
            else str[tot++]=ss[i];
        }
    }
    
    bool cmp(Node a,Node b)
    {
        return a.a>b.a;
    }
    
    int main()
    {
        int i,ans,cas,flag,cot;
        init();
        while(gets(ss))
        {
            flag=0;
            if(ss[0]=='0') break;
            int len=strlen(ss);
            ss[len]=' ';
            ss[len+1]='\0';
            get_num();
            ans=1;
            for(i=0; i<cnt; i+=2)
            {
                ans*=pow(num[i],num[i+1]);
            }
            ans-=1;
            cot=0;
            for(i=0; i<tes; i++)
            {
                if(ans==1) break;
                if(ans%prime[i]==0)
                {
                  rem[cot].a=prime[i];
                }
                cas=0;
                while(ans%prime[i]==0)
                {
                    cas++;
                    ans/=prime[i];
                }
                if(cas)  rem[cot++].b=cas;
            }
            sort(rem,rem+cot,cmp);
            for(i=0;i<cot;i++)
            {
                if(i==0)printf("%d %d",rem[i].a,rem[i].b);
                else printf(" %d %d",rem[i].a,rem[i].b);
            }
            printf("\n");
    
    
        }
        return 0;
    }
  • 相关阅读:
    关于苹果IPhone/Ipad(IOS)开发者证书申请及安装、真机调试、发布的参考文章
    vs 关闭警告
    真机测试及布署Code Sign error问题总结
    在 Win32 Application 和 Win32 Console Application 中使用 MFC
    获取应用程序路径的区别
    js日期控件
    SQL SERVER 企业管理器 MMC 无法创建管理单元
    进程查看两利器
    用PowerDesigner逆向数据库工程时”Unable to list the table"错误的解决方法
    SQL 附加无日志数据库
  • 原文地址:https://www.cnblogs.com/zsboy/p/2651432.html
Copyright © 2011-2022 走看看