zoukankan      html  css  js  c++  java
  • 排序

    Problem Description

    These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
    Give you some integers, your task is to sort these number ascending (升序).
    You should know how easy the problem is now!
    Good luck!

    Input

    Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
    It is guarantied that all integers are in the range of 32-int.

    Output

    For each case, print the sorting result, and one line one case.

    Sample Input

    2 3 2 1 3 9 1 4 7 2 5 8 3 6 9

    Sample Output

    1 2 3 1 2 3 4 5 6 7 8 9

    #include<stdio.h>
    int main()
    {
        int t, n, num[100000];
        int i, j, k, a;
        scanf( "%d", &t );
               for( i = 0 ; i < t; i++ )
                  {
                      scanf( "%d" , &n );
                      for( j = 0 ; j < n ; j++ )
                          scanf( "%d", &num[j] );
                             for(  a = 0; a < (n-1); a++ )
                                for( j = 0; j < ((n-1)-a); j++ )
                                  if( num[j] > num[j+1] )
                                  {
                                      k = num[j]; num[j] = num[j+1]; num[j+1] = k;
                                  
                              for( j = 0 ; j < n ; j++ )
                                  printf( j == (n-1) ? "%d\n" : "%d ", num[j] );
                  }
          getchar();getchar();
          return 0;
    }

  • 相关阅读:
    [转]CentOS 修改yum源为国内源
    著名的镜像网站
    [译]LRTHW练习五——更多的变量及输出打印
    CentOS足迹一
    LRTHW笔记二
    线程的创建和运行(未完待续)
    比较当前时间和给定时间大小
    单独管理image
    Java 修改页面排序条件
    Java 如何使用radio button保存值
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2250535.html
Copyright © 2011-2022 走看看