zoukankan      html  css  js  c++  java
  • Switch Game(摘自LP学C++)

    杭电acm 2053 Switch Game
    2010-07-20 11:39

    Switch Game

    Time Limit: 1000/1000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3425     Accepted Submission(s): 2007

    Problem Description

    There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

    //有一些灯排成一条直线。所有的灯在刚开始都是关闭的,在对灯进行一系列操作后:在第i次操作的时候,调整所有标号是i的倍数的灯的状态(原本打开的灯将它关闭,原本关闭的将它打开)。

    Input
    Each test case contains only a number n ( 0< n<= 10^5) in a line.
     
    Output
    Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
     
    Sample Input
    1 5
     
    Sample Output
    1 0
    Hint
    hint
    Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

    #include<iostream>
    using namespace
    std;
    int
    main()
    {

        int
    n;
        while
    (cin>>n)
        {
       int c=0;
            for
    (int i = 1; i <= n; ++i)
            {

                if
    (n%i==0)
                    c++;
            }

           
            cout<<(c%2==0? 0:1)<<endl;
        }

        return
    0;
    }

    一位大牛的分析:

    我们举个简单的例子来看看它的规律:
    比如n=16,则在第1、2、4、8、16次操作的时候,第16号灯都会被调整,因为16是1、2、4、8、16的倍数。
    共有5次,因为开始是关闭的,所以最后将是亮着的。
    你可能已经发现,其实求第n盏灯最后的状态,只是求它的因子个数的奇偶性(因为对同一盏等调整两次就恢复原状态)。
    下面的代码就可以AC了。

    #include <stdio.h>

    int main(void)
    {
        int i, c, n;
        while (scanf("%d", &n) != EOF)
        {       
            for (i = 1, c= 0; i <= n; i++)
            {
                if (n % i == 0)
                    c++;
            }
            printf("%d\n", c & 1);
        }

        return 0;
    }

    但你继续往下思考一下。是不是又发现了什么呢?
    因子是不会只有1个的,比如16 = 1 * 16 = 2 * 8 = 4 * 4
    所以,因为A = a × b,如果所有的因子a都不等于b,则因子的个数一定是偶数。
    唯一使A的因子的个数为奇数的可能是存在A = a × b 且 a = b。即A是完全平方数。就像刚刚的16 = 4 × 4。
    所以只要判断输入的数是否为完全平方数即可。

     
    #include <math.h> #include <stdio.h> #define S(x) (((int)x)*((int)x)) int main(void) { int n; while (scanf("%d", &n) != EOF) printf("%d\n", S(sqrt(n)) == n); return 0; }
    
    #include <math.h>
    #include <stdio.h>
    #define S(x) (((int)x)*((int)x))
    int main(void)
    {
        int n;
        while (scanf("%d", &n) != EOF)
            printf("%d\n", S(sqrt(n)) == n);
    
        return 0;
    }
  • 相关阅读:
    Unix网络编程中的五种IO模型
    go工具库分析——go-snowflake
    defer
    滑动窗口
    快速幂
    Golang使用注意点
    微服务数据一致性基础认知
    KMP算法
    单调栈和单调队列
    LRU简单学习
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2266813.html
Copyright © 2011-2022 走看看