zoukankan      html  css  js  c++  java
  • Binary Tree

    POJ 2499  (简单二叉树)

                                                                                                                                              Binary Tree
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 6004   Accepted: 2781

    Description

    Background
    Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:
    • The root contains the pair (1, 1).
    • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

    Problem
    Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

    Input

    The first line contains the number of scenarios.
    Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent
    a node (i, j). You can assume that this is a valid node in the binary tree described above.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

    Sample Input

    3
    42 1
    3 4
    17 73

    Sample Output

    Scenario #1:
    41 0
    
    Scenario #2:
    2 1
    
    Scenario #3:
    4 6
    
    #include<iostream>
    using namespace std;
    int main()
    {
    	int l,r,x,y,n,i;
    	cin>>n; 
    	int up;
    	for(i=0;i<n;i++)
    	{
    		cin>>x>>y;
    		l=r=0;
    		while( x>1||y>1 )
    		{
    			if(x>y)
    			{
    			  up=(x-1)/y;
    			  l=l+up;
    			  x=x-up*y;
    			}
    			else
    			{
     			  up=(y-1)/x;
    			  r=r+up;
    			 y=y-up*x;
    			}	
    		}
    		cout<<"Scenario #"<<i+1<<':'<<endl;
    		cout<<l<<' '<<r<<endl<<endl;
    	}
    	return 0 ;
    }


     

  • 相关阅读:
    药方
    Git配置
    黄俊俊:做一个有想法的技术人
    刘铁猛:程序员:造阀门前,先蓄满‘情商池’
    Nginx + Tomcat 配置负载均衡集群简单实例
    mysql 用户权限管理详细
    mysql数据权限操作
    搭建分布式系统
    数据库 -- 悲观锁与乐观锁
    tomcat7以下线程控制
  • 原文地址:https://www.cnblogs.com/zswbky/p/5432108.html
Copyright © 2011-2022 走看看