zoukankan      html  css  js  c++  java
  • (超简单并查集)POJ2524 Ubiquitous Religions(8.4.4)

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    

    仅注意格式即可超简单

    #include<cstdio>
    #include <iostream>
    #include<cstring>
    using namespace std;
    int set[50005];
    
    int set_find(int x){//查找的是父亲节点 
     if(set[x]<0)  return x;//返回本身,作为根节点 
     return set[x]=set_find(set[x]);
    }
    
    int main (){
     int n,m,a,b,Case=0,count;
     while(cin>>n>>m){//多组测试数据 
          Case++,count=0;
          if(m==0&&n==0)   break;
          memset(set,-1,sizeof(set));//初始化为负数 
          for(int i=1;i<=m;i++){
               cin>>a>>b;
               int p=set_find(a),q=set_find(b);//p q 记录两个的根节点 
               if(p!=q){//如果两个不是同一个根节点,就将其合并 
                 set[q]=p;//合并 
                 count++;//增加一路分支 
               }
          }
         cout<<"Case "<<Case<<": "<<n-count<<endl;
     }
      return 0;
    }
    


     

  • 相关阅读:
    Python字符编码补充
    shell脚本自动部署及监控
    【Linux】应用程序内存段布局
    【Linux】Core dump故障分析
    【Linux】GDB程序调试
    【Linux】小应用 大智慧
    【嵌入式】安装Linux系统到开发板
    【读书笔记】高效演讲
    【Linux】GCC编译
    【Linux】Linux 找回Root用户密码
  • 原文地址:https://www.cnblogs.com/zswbky/p/5432110.html
Copyright © 2011-2022 走看看