zoukankan      html  css  js  c++  java
  • (并查集 )A

    Description

    The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

    Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

    1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

    2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

    Output

    For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

    Sample Input

    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4
    

    Sample Output

    Not sure yet.
    In different gangs.
    In the same gang.
    

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    using namespace std;
    const int maxn=100000 +5;

    int n,m;
    int set[maxn +maxn];

    int set_find(int d)
    {
     if(set[d]<0)
      return d;
     return set[d]=set_find(set[d]);//路径压缩并查找,是一边查找一边压缩
    }

    int main()
    {
     int loop;
     int i;
     scanf("%d",&loop);
     while(loop--)
     {
      scanf("%d%d",&n,&m);
      
      memset(set,-1,sizeof(set));
      for(i=0;i<m;i++)
      {
       int a,b;
       char s[5]; 
       
       scanf("%s%d%d",s,&a,&b);
       if(s[0]=='A')
       {
        
        if(set_find(a)!=set_find(b)&&set_find(a)!=set_find(b+n))
                                                //set_find(a)!=set_find(b)是不在同一个帮派中的
                     //set_find(a)!=set_find(b+n)不在相反的帮派中
         printf("%s ","Not sure yet.");
        else
         if(set_find(a)==set_find(b))           
          printf("%s ","In the same gang.");
         else
          printf("%s ","In different gangs.");
       }
       else
        if(set_find(a)!=set_find(b+n))     // set_find(a)!=set_find(b)是不在同一个帮派中的  
        {
         set[set_find(a)]=set_find(b+n);
         set[set_find(b)]=set_find(a+n);
        }
      }
     }
     return 0;
    }

  • 相关阅读:
    SpringBoot-整合Shiro和JWT时关于JWT部分的内容
    springboot常用注解分类整理
    ubuntu18.04 安装tomcat9
    Ubuntu 18.04 安装Tomcat9 遇到的问题Tomcat9 Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
    Ubuntu 18.04 上安装水下网络仿真器Aqua-Sim NG
    用gorm向mysql插入的时间数据和实际时间不一致问题
    Ubuntu18.04上安装NS-3
    Java集合用法
    Spring Boot 自动装配原理
    深入理解select、poll和epoll及区别
  • 原文地址:https://www.cnblogs.com/zswbky/p/5432113.html
Copyright © 2011-2022 走看看