zoukankan      html  css  js  c++  java
  • Balloons(山东省第一届ACM省赛)

    Balloons

     

    Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

    题目描述

    Both Saya and Kudo like balloons. One day, they heard that in the central park, there will be thousands of people fly balloons to pattern a big image.
    They were very interested about this event, and also curious about the image.
    Since there are too many balloons, it is very hard for them to compute anything they need. Can you help them?
    You can assume that the image is an N*N matrix, while each element can be either balloons or blank.
    Suppose element and element B are both balloons. They are connected if:
    i) They are adjacent;
    ii) There is a list of element C1C2, … , Cn, while A and C1 are connected, C1 and C2 are connected …Cn and B are connected.
    And a connected block means that every pair of elements in the block is connected, while any element in the block is not connected with any element out of the block.
    To Saya, element A(xa,ya)and B(xb,yb) is adjacent if |xa-xb| + |ya-yb|  1 
    But to Kudo, element A(xa,ya) and element B (xb,yb) is adjacent if |xa-xb|≤1 and |ya-yb|1
    They want to know that there’s how many connected blocks with there own definition of adjacent?

    输入

    The input consists of several test cases.
    The first line of input in each test case contains one integer N (0<N100), which represents the size of the matrix.
    Each of the next N lines contains a string whose length is N, represents the elements of the matrix. The string only consists of 0 and 1, while 0 represents a block and 1represents balloons.
    The last case is followed by a line containing one zero.

    输出

     For each case, print the case number (1, 2 …) and the connected block’s numbers with Saya and Kudo’s definition. Your output format should imitate the sample output. Print a blank line after each test case.

    示例输入

    5
    11001
    00100
    11111
    11010
    10010
    
    0

    示例输出

    Case 1: 3 2

    题目链接:http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2152


    简单水题:

    直接神搜就行了,每一块是气球的都遍历一下,看是否能够成一块新的,然后计数就好了。

    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <algorithm>
    #include <string>
    #include <string.h>
    using namespace std;
    #define MAX 500
    #define INF 0x3f3f3f3f
    int dir[8][2]={{-1,0},{1,0},{0,-1},{0,1},{-1,-1},{-1,1},{1,-1},{1,1}};
    int n;
    bool mark[105][105];
    char ch[105][105];
    int ffind=-1; ///标记是哪个人的
    bool dfs(int x,int y){
       if(x<0||y<0||x>=n||y>=n) return false;
       if(mark[x][y]==1||ch[x][y]=='0') return false;
    
       mark[x][y]=1;
       int mmax;
       ffind==1 ? mmax=4 : mmax=8;
    
       for(int i=0;i<mmax;i++)
           dfs(x+dir[i][0],y+dir[i][1]);
       return true;
    }
    
    int main (){
        int cnt=1;
        while(scanf("%d",&n)&&n!=0){
    
            for(int i=0;i<n;i++)
                scanf("%s",ch[i]);
            int sum1=0,sum2=0;
    
            //求解第一个人的
            memset(mark,0,sizeof(mark));  
            ffind=1;
            for(int i=0;i<n;i++)
              for(int j=0;j<n;j++)
                if(dfs(i,j)) sum1++;
            //求解第二个人用的
            memset(mark,0,sizeof(mark));
            ffind=2;
            for(int i=0;i<n;i++)
              for(int j=0;j<n;j++)
                if(dfs(i,j)) sum2++;
            printf("Case %d: %d %d
    
    ",cnt++,sum1,sum2);
        }
    }
    











  • 相关阅读:
    js变量类型
    js词法分析
    ORACLE 查找字段在哪些表里存在
    主外键约束的关闭和启用
    pl/sql developer 编码格式设置(转)
    WIN7 Net Configuration Assistant打不开
    Kettle 连接失败 Oracle 数据库报 ora-12505 的解决方法(转)
    正则表达式30分钟入门教程(转)
    设置程序的多个入口,进行动态的显示
    应用多入口配置
  • 原文地址:https://www.cnblogs.com/zswbky/p/5432169.html
Copyright © 2011-2022 走看看