zoukankan      html  css  js  c++  java
  • Crossing River

    Crossing River
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 11814   Accepted: 4476

    Description

    A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

    Output

    For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

    Sample Input

    1
    4
    1 2 5 10
    

    Sample Output

    17


    题目大意&解题思路:
    一些人想要过河,例如4个人过河的所需时间分别为:1,2,5,10
    那么过河有两种方法:
    1. 1与2,1回来,1与5,1回来,1与10 结果耗时19
    2. 1yu2,2回来,5与10,1回来,1与2 结果耗时15

    总结两种方法:
    设 x,y为最快和次快,a,b为次慢和最慢
    那么第一种耗时t=y+x+a+x+b
    第二种耗时t=y+y+b+x+y

    重点就在于2*y和x+a谁大谁小

    根据贪心的思想,每一次都比较一下呗
    谁小选谁

    代码:


    #include"iostream"
    #include"algorithm"
    using namespace std;
    int a[1010];
    int main()
    {
    int T,n,sum;
    cin>>T;
    while(T--){
    cin>>n;
    for(int k=0;k<n;k++){
    cin>>a[k];
    }
    sum=0;
    sort(a,a+n);
    if(n==1)
    sum+=a[0];
    while(n>1)
    {
    if(n==2)
    sum+=a[1];
    if(n==3)
    sum+=(a[0]+a[1]+a[2]);
    if(n>=4)
    {
    if(2*a[1]-a[n-2]-a[0]<0)
    {
    sum+=(a[0]+2*a[1]+a[n-1]);
    }
    else
    {
    sum+=(2*a[0]+a[n-2]+a[n-1]);
    }
    }
    n-=2;
    }
    cout<<sum<<endl;
    }

    return 0;
    };

  • 相关阅读:
    IDEA热部署插件JRebel使用
    IntelliJ IDEA 代码注释
    解决redis显示中文为乱码问题
    C#的六种修饰符
    Bat批处理把文件夹包括子文件夹下面的某个文件复制到另一个目录下
    html不识别<br/>,后台返回<br/>,前端不换行解决办法
    C# Task的应用
    c# 生成json字符串和解析json字符串处理
    在 C# 中将 List<dynamic> 转换为 List<string>
    C#读取主从文件的excel并把结果为pass的文件打包
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4652644.html
Copyright © 2011-2022 走看看