zoukankan      html  css  js  c++  java
  • 集训第五周动态规划 G题 回文串

    Description
    A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

    As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

    Input

    Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

    Output

    Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

    Sample Input

    5
    Ab3bd

    Sample Output

    2

    这道题类似于编辑距离,使用动态规划可解:

    用dp(i,j)表示数组从i到j的这个区间形成的子串,使其成为回文串需要加入最小的字符个数

    那么动态规划方程为
    1.min(dp(i+1,j)+1,dp(i,j-1)+1) (a[i]!=a[j])
    dp(i,j)={
    2.dp(i+1,j-1) (a[i]=a[j])

    这道题由于n最大可达5000,因此使用int型的二维数组会超空间,可以把int型改成short型,同时也可以使用滚动数组,因为这个状态转移方程是在两个相邻的
    状态之间转变,因此使用两行一列的数组就完全可以存下,而且这个DP也类似于递推,由已知推未知,本就用不到那么多的空间,可以覆盖掉那些没用的,只保存有用的就行。

    #include"iostream"
    #include"cstring"
    using namespace std;

    const int maxn=5010;
    char a[maxn];
    int dp[2][maxn],n;

    void Init()
    {

    for(int i=1;i<=n;i++) {cin>>a[i];}
    memset(dp,0,sizeof(dp));
    }

    void Work()
    {
    for(int i=n-1;i>=1;i--)
    {
    for(int j=i+1;j<=n;j++)
    {
    if(a[i]==a[j])
    dp[i%2][j]=dp[(i+1)%2][j-1];
    else
    dp[i%2][j]=min(dp[(i+1)%2][j],dp[i%2][j-1])+1;
    }
    }
    }

    void Print()
    {
    cout<<dp[1][n]<<endl;
    }

    int main()
    {
    while(cin>>n)
    {
    Init();
    Work();
    Print();
    }
    return 0;
    }

    
    
    
     
    #include"iostream"
    #include"cstring"
    using namespace std;
    
    const int maxn=5010;
    char a[maxn];
    short dp[maxn][maxn],n;
    
    void Init()
    {
    
    for(int i=1;i<=n;i++) {cin>>a[i];}
    memset(dp,0x3f,sizeof(dp));
    }
    
    void Work()
    {
    for(int i=1;i<=n;i++) {dp[i][i]=0;dp[i+1][i]=0;}
    for(int i=n-1;i>=1;i--)
    {
    for(int j=i+1;j<=n;j++)
    {
    if(a[i]==a[j])
    dp[i][j]=dp[i+1][j-1];
    else
    dp[i][j]=min(dp[i+1][j],dp[i][j-1])+1;
    }
    }
    }
    
    void Print()
    {
    cout<<dp[1][n]<<endl;
    }
    
    int main()
    {
    while(cin>>n)
    {
    Init();
    Work();
    Print();
    }
    return 0;
    }
    View Code
    
    
    
     
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    const int maxn=5000+10;
    char a[maxn];
    short dp[maxn][maxn];
    int main()
    {
        int n;
        while(cin>>n)
        {
         memset(dp,0x3f,sizeof(dp));
         for(int i=1;i<=n;i++) cin>>a[i];
         for(int i=1;i<=n;i++)
         {
             dp[i-1][i]=0;
             dp[i][i]=0;
         }
         for(int i=2;i<=n;i++)
         for(int j=i-1;j>=1;j--)
         {
             if(a[i]==a[j]) dp[i][j]=dp[i-1][j+1];
             else           dp[i][j]=min(dp[i-1][j]+1,dp[i][j+1]+1);
         }
         cout<<dp[n][1]<<endl;
        }
        return 0;
    }
    View Code
    
    
    





  • 相关阅读:
    linux笔记2.20
    新安装ubuntu后几项配置
    linux网络配置
    linux笔记2.19
    jquery在不同浏览器获取文件路径出现问题!
    软件工程师如何定义自己的职业路线
    标识符
    结对项目-四则运算 “软件”之升级版
    小学四则运算 “软件”之初版
    分布式版本控制系统Git的安装与使用
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4725487.html
Copyright © 2011-2022 走看看