zoukankan      html  css  js  c++  java
  • 集训第六周 数学概念与方法 数论 线性方程 I题

    Description

    The Sky is Sprite. 
    The Birds is Fly in the Sky. 
    The Wind is Wonderful. 
    Blew Throw the Trees 
    Trees are Shaking, Leaves are Falling. 
    Lovers Walk passing, and so are You. 
    ................................Write in English class by yifenfei 



    Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
    Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 
     

    Input

    The input contains multiple test cases. 
    Each case two nonnegative integer a,b (0<a, b<=2^31) 
     

    Output

    output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
     

    Sample Input

    77 51
    10 44
    34 79
     

    Sample Output

    2 -3
    sorry
    7 -3
     
    给出 a1 a2
    求 x1 x2 使得 a1*x1+a2*x2=1
    如果不存在,输出sorry
    套用扩展欧里几得算法的模版
    注意输出不需要考虑最后的空格控制
    注意x1要大于0
     
    #include"iostream"
    using namespace std;
    
    void gcd(int a,int b,int &d,int &x,int &y)
    {
        if(!b) {d=a;x=1;y=0;}
        else {gcd(b,a%b,d,y,x);y-=x*(a/b);}
    }
    
    int main()
    {
        int m,n;
        while(cin>>m>>n)
        {
         int x,y,d;
         gcd(m,n,d,x,y);
         if(d!=1) cout<<"sorry"<<endl;
         else
         {
             while(x<0)
             {
                 x+=n;
                 y-=m;
             }
             cout<<x<<" "<<y<<endl;
         }
        }
        return 0;
    }
     
     
     
  • 相关阅读:
    golang 使用错误总结
    golang 跨平台交叉编译
    golang redis 第三方包
    golang 浮点型 与其他数值类型计算
    golang 更友好的格式化输出
    golang 指定长度 随机数 & 随机字符串
    go语言中int和byte转换方式
    基础知识
    golang bytes 包 详解
    golang 解析 ini 文件 中文文档
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4744562.html
Copyright © 2011-2022 走看看